The default bug view has changed. See this FAQ.

identities list does not refresh the list after an identity is edited or added

VERIFIED FIXED in Thunderbird 16.0

Status

MailNews Core
Account Manager
--
critical
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

({regression})

Trunk
Thunderbird 16.0
regression

Thunderbird Tracking Flags

(thunderbird14+ fixed, thunderbird15+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

5.97 KB, patch
standard8
: review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
After an identity is edited or added, the list is not refreshed so it does not show the change or new identity. The dialog must be closed and opened again to see new values.
This is caused by the am-identity-edit.xul/js not returning .result = true in the window arguments. That in turn is caused by failure in onOK() due to this:

Error: prettyFolderName is not defined
Source File: chrome://messenger/content/am-copies.js
Line: 159

The error is normally hidden but I added try {} catch {} to find it. This must be fallout from bug 451728.
However I am not sure why it happens. am-identity-edit.xul includes and overlay from am-copiesOverlay.xul that in turn includes amUtils.js which includes the prettyFolderName function.

I have noticed this in TB16. But bug 451728 went into TB14. I have not tested that one yet, but if the problem is there, I must fix this ASAP, so setting the flag (wonder why there is no tracking-thunderbird15 flag).
(Assignee)

Comment 1

5 years ago
Well, the is now a tracking-thunderbird15 flag, but it was not accessible directly in the bug creation form (a bug in bugzilla?) while the others are.
tracking-thunderbird15: --- → ?
(Assignee)

Comment 2

5 years ago
You can also see a manifestation of the bug by going into an identity and seeing the Copies&folders tab. Some of the folderpickers may be empty, even though they should be initialized to the values set at the main identity on the main Copies&folder pane of the account.
(Assignee)

Comment 3

5 years ago
I can confirm the problem is in TB14.
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 4

5 years ago
Created attachment 637275 [details] [diff] [review]
patch

It looks like the file amUtils.js was not properly loaded into the am-copiesOverlay.xul due to duplicate constant nsIFilePicker definition (it was in both files). I have no idea why it wasn't a problem when the same overlay was loaded in the Copies&Folders pane.
Attachment #637275 - Flags: review?(mbanner)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

5 years ago
Created attachment 637281 [details] [diff] [review]
patch v2

Better checkin message.
Attachment #637275 - Attachment is obsolete: true
Attachment #637275 - Flags: review?(mbanner)
Attachment #637281 - Flags: review?(mbanner)
Comment on attachment 637281 [details] [diff] [review]
patch v2

Looks good, r=me and a=me for landing on the branches.
Attachment #637281 - Flags: review?(mbanner)
Attachment #637281 - Flags: review+
Attachment #637281 - Flags: approval-comm-beta+
Attachment #637281 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/comm-central/rev/9128c033ee05

I'll do branches later.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
tracking-thunderbird14: ? → +
tracking-thunderbird15: ? → +
Keywords: regression
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 16.0
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/082722bf72f6
https://hg.mozilla.org/releases/comm-beta/rev/9e738cd01a38
status-thunderbird14: --- → fixed
status-thunderbird15: --- → fixed
Duplicate of this bug: 476044
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.