Better naming for Sync devices

RESOLVED DUPLICATE of bug 679272

Status

Cloud Services
Firefox Sync: UI
RESOLVED DUPLICATE of bug 679272
6 years ago
6 years ago

People

(Reporter: lsof, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120616215704

Steps to reproduce:

Firefox generates a description for my computer, it looks like this:
 USERNAME's Firefox on Linux x86_64

If I have two Linux computers, I can't tell them apart.

It would be nice if the following format was used:
 USERNAME's Firefox on HOSTNAME (Linux x86_64)

Comment 1

6 years ago
Our device naming is currently horrible. It is on our list of things to make better.

In the mean time, you can change your device's name through the Sync preferences pane. I /think/ the device names are cached after the initial sync when you open the application. So, you may have to restart Firefox for the changes to take effect. I think we have a bug on that somewhere.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

6 years ago
As a workaround, can the output from uname -n be put into the string?

I have three PCs which Firefox generates the same identifier for. It's confusing.

Comment 3

6 years ago
I doubt we will ever put the output of `uname` in the user-visible device name because most Firefox users don't know and don't care what the hostname of their device is. It's typically only power users who care about such a thing. If a user cares about the device, it's usually phone vs desktop vs laptop vs tablet or similar.

I'll keep this bug open for tracking improvements to the clients record in Sync 2.0 (although we may have a bug for that, so this may get duped in the future).
(Reporter)

Comment 4

6 years ago
If the string is an identifier, it makes sense that it is unique. If it is unique, it makes sense to use something the user already understands. Only power users will look at that field anyway.
We probably want to integrate this with device management, and probably introduce custom naming.
Blocks: 821532
Summary: description of sync host should include hostname → Better naming for Sync devices
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679272
Blocks: 670474
Blocks: 618509
No longer blocks: 618509
You need to log in before you can comment on or make changes to this bug.