Last Comment Bug 768925 - API for WebTelephony conference calls
: API for WebTelephony conference calls
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Jonas Sicking (:sicking) PTO Until July 5th
:
Mentors:
Depends on:
Blocks: 772761 772765
  Show dependency treegraph
 
Reported: 2012-06-27 09:08 PDT by Andrew Overholt [:overholt]
Modified: 2013-09-16 07:07 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
koi+
-
fixed


Attachments

Description Andrew Overholt [:overholt] 2012-06-27 09:08:01 PDT
We need to spec the API for WebTelephony conference calls.
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-30 11:44:04 PDT
Me and Bent talked through this and came up with an API:

https://wiki.mozilla.org/WebAPI/WebTelephony#DOM_API

I wanted to keep things simple for now since GSM doesn't support multiple simultaneous conference groups as far as we could tell. So there's a static mozTelephony.conferanceGroup property which contains the one group that you can use.

Adding and removing calls to that group is straight-forward by calling group.add and group.remove. Only quirk is that the group can't contain just one call (since then it's not a group), so the first time you have to call .add and provide two call objects.

Swiching between a group and a call on hold, or simply between two different calls, is done by calling .resume on the group/call that you want to switch to. That will automatically put the currently active group/call on hold.

So now we just need someone to implement :)
Comment 2 Philipp von Weitershausen [:philikon] 2012-07-02 15:37:07 PDT
(In reply to Jonas Sicking (:sicking) from comment #1)
> Me and Bent talked through this and came up with an API:
> 
> https://wiki.mozilla.org/WebAPI/WebTelephony#DOM_API
> 
> I wanted to keep things simple for now since GSM doesn't support multiple
> simultaneous conference groups as far as we could tell. So there's a static
> mozTelephony.conferanceGroup property which contains the one group that you
> can use.

Is "conferance" just a typo of "conference" or an actual word? *playing the ESL card*

> So now we just need someone to implement :)

I thought this was the point of this bug? At least it seemed like Hsin-Yi was volunteering ;).
Comment 3 Hsin-Yi Tsai [:hsinyi] 2012-07-04 07:48:13 PDT
Hah~ yes, if no body is working on this, then I'd like to take this challenge. :)
Comment 4 Hsin-Yi Tsai [:hsinyi] 2012-07-10 04:21:47 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #2)
> 
> 
> > So now we just need someone to implement :)
> 
> I thought this was the point of this bug? At least it seemed like Hsin-Yi
> was volunteering ;).

(In reply to Hsin-Yi Tsai [:hsinyi] from comment #3)
> Hah~ yes, if no body is working on this, then I'd like to take this
> challenge. :)
Hi, 

I am studying conference calls and gonna file two bugs for implementing this API. One focuses on DOM implementation and the other on RIL. 

Right before I file and take the new bugs, I wanna ask again, if anyone is working on the implementation? If no, then may I take them? 
Thanks. :)
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-10 07:08:44 PDT
(In reply to Philipp von Weitershausen [:philikon] from comment #2)
> (In reply to Jonas Sicking (:sicking) from comment #1)
> Is "conferance" just a typo of "conference" or an actual word?

typo!
Comment 6 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-07-10 07:12:43 PDT
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #4)
> Right before I file and take the new bugs, I wanna ask again, if anyone is
> working on the implementation? If no, then may I take them? 

All yours! (Fair warning, though: this may prove to be a tricky first DOM bug!)
Comment 7 Joe Cheng [:jcheng] 2013-07-08 01:33:40 PDT
listed as must have in v1.2 for COMM team. koi+

Note You need to log in before you can comment on or make changes to this bug.