http or ftp download stalls Fizzilla

VERIFIED DUPLICATE of bug 85514

Status

()

Core
Networking
VERIFIED DUPLICATE of bug 85514
18 years ago
17 years ago

People

(Reporter: Kimon, Assigned: Steve Dagley)

Tracking

({qawanted})

Trunk
PowerPC
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: OSX++)

(Reporter)

Description

18 years ago
Fizzilla on Mac OS X (10.0.1) is very inconsistent about downloads.
Both HTTP and FTP downloads stall 4 out of 5 times (on big file sizes, >10MB),
but for smaller sizes, it is sometimes possible to download succesfully.

Comment 1

17 years ago
Platform: PowerBook G3/300/192Mb/30Gb, MacOS X 10.0.3
Build: Fizzilla 20010509

Downloading files doesn't work properly in the new build at all, regardless of
file size. For example, go here:

http://www.versiontracker.com/moreinfo.fcgi?id=9472

and click on the "Download Now" link. You'll be asked how to download the file.
Try clicking "OK". The hidden window will come forward, and then Moz will become
locked to any further use. When I choose Quit from the Mozilla menu, sometimes
it quits, sometimes it locks up, sometimes it crashes.

You should also experiment with http based downloads from versiontracker.com to
see that they work properly too.

- Adam
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: fizzilla build 20010418 stalling on downloads → http or ftp download stalls Fizzilla

Updated

17 years ago
Keywords: qawanted

Comment 2

17 years ago
->dougt and futured.
Assignee: neeti → dougt
Target Milestone: --- → Future
wanted for rtm, not future. does macos9 still have this problem? simon, can you 
comment?
Keywords: mozilla0.9.2, rtm
Target Milestone: Future → ---

Comment 4

17 years ago
I believe downloads work correctly on Mac OS 9 (tever, please test thoroughly). I 
think downloads on Mac OS X will be haunted by the problems described in bug 
71718.
(Assignee)

Updated

17 years ago
Whiteboard: OSX+

Comment 5

17 years ago
to gagan for possible reassignment
Assignee: dougt → gagan

Comment 6

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 7

17 years ago
sdagley: per simon's comments this may be related to your bug 71718 Can you look 
at this one too after you fix that one?  Thanks
Assignee: gagan → sdagley
beta stopper, but i can be convinced otherwise
Whiteboard: OSX+ → OSX++
(Assignee)

Comment 9

17 years ago
Marking this as a dupe of #85514 as that's the one where we figured out we need 
to use OTEnter/LeaveNotifier() to prevent OT notifiers from firing while we're 
reading data in SendReceiveStream() and clobbering the i/o state.  This fix was 
checked in 6/13 but the 6/13 Fizilla builds were made earlier in the day so 
there's no build this is verifiable in yet.


*** This bug has been marked as a duplicate of 85514 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 10

17 years ago
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.