Closed Bug 76901 Opened 19 years ago Closed 18 years ago

holding down mouse click stalls downloading

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 106689
mozilla1.1alpha

People

(Reporter: kimon, Assigned: mikepinkerton)

Details

using fizzilla build 20010418 in MacOS X (I suspect under classic Mac OS as
well) while downloading any file, clicking and holding the mouse button for a
few seconds manages to stall the download process.
doesn't happen on os9, 5/22/01 build. i doubt it would happen on x, but who 
knows.
Marking WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
QA contact updated
QA Contact: gerardok → madhur
can anyone who has MacOS X - verify if this bug is existing.
Thanks!!
I apologize for not being thorough enough the first time I reported the bug.

The problem still occurs in MacOS X using build: 2001091621 and in 
Classic using: 2001091708 (this is classic environment in OSX)

To reproduce:
a) use a tool like Net Monitor to be able to visually see network activity
b) mouse down & hold on the titlebar of the download window (or any 
other Mozilla window) and download flat-lines. Once mouse is released, 
download resumes again.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Using build id: 2001091108 on MacOS 8.6 I reproduce the bug, when downloading a
mozilla build, if i press the mouse button the download stops till I release the
button.
After looking at possible Dups and after Basic advise.
Marking as New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Replacing the event manager code with Carbon event code should fix this, and a
number of other problems, see bug# 106397
Depends on: 106397
-> pinkerton, probably post moz 1.0
Assignee: joki → pinkerton
Target Milestone: --- → mozilla1.1
where are you holding the mouse down? i can't duplicate this at all with NS6.2
on OSX unless I hold the mouse down in the title bar or the menubar. then this
is a dupe of my carbon event bugs and not really a real bug on its own.

*** This bug has been marked as a duplicate of 106689 ***
Status: NEW → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → DUPLICATE
QA Contact: madhur → rakeshmishra
QA Contact: rakeshmishra → trix
No longer depends on: 106397
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.