Closed Bug 769017 Opened 8 years ago Closed 8 years ago

Log parser doesn't catch this mochitest failure - treats it as 'success': ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_traffic_jam.html | expect it to be fired at the transaction

Categories

(Core :: Storage: IndexedDB, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 770046

People

(Reporter: dholbert, Unassigned)

References

()

Details

Attachments

(1 file)

See this mochitest log:

https://tbpl.mozilla.org/php/getParsedLog.php?id=13045396&full=1&branch=try
Rev3 Fedora 12x64 try debug test mochitests-2/5 on 2012-06-27 11:35:05 PDT for push 8ca66050cc01

It helpfully highlights this mochitest failure:
{
2 ERROR TEST-UNEXPECTED-FAIL | /tests/dom/indexedDB/test/test_traffic_jam.html | expect it to be fired at the transaction - got [object IDBTransaction @ 0x1ac3280 (native @ 0x14999c0)], expected null
}

...but then it says:

{
builder: try_fedora64-debug_test-mochitests-2
slave: talos-r3-fed64-005
starttime: 1340822105.55
results: success (0)
buildid: 20120627105315
builduid: 021aedc2057c4fa399b69eb5e36f6558
revision: 8ca66050cc01
}

ACTUAL RESULTS:   "results: success" in the block above
EXPECTED RESULTS: "results: warnings (1)"

IIRC, that "results" line is what makes the log colored green vs. orange.
(CC'ing armenzg_buildduty for triage / investigation.)
Attached file raw log (gzipped)
For reference, here's a copy of the (gzipped) full raw log.
Assignee: nobody → jlund
So, this test is broken. The log parser determines the pass/fail status from the summary at the end:
23417 INFO Passed: 211977
23418 INFO Failed: 0
23419 INFO Todo:   21394

It's not showing up as an actual failure.
Assignee: jlund → nobody
Component: Release Engineering → DOM: IndexedDB
Product: mozilla.org → Core
QA Contact: release → indexeddb
Version: other → Trunk
This is bent's crazy test_ipc setup.
No longer blocks: 587797
Duplicate of this bug: 770046
Duping forward to the bug that explains how to fix it.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770046
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #4)
> This is bent's crazy test_ipc setup.

s/crazy/awesome/ ;)
(In reply to ben turner [:bent] from comment #7)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #4)
> > This is bent's crazy test_ipc setup.
> 
> s/crazy/awesome/ ;)

true, IFF we want to ignore any and all failures.

I can concede it can be true, in the future, IFF we don't ignore failures.
You need to log in before you can comment on or make changes to this bug.