Last Comment Bug 769077 - Uninitialized render buffers do not report memory usage correctly
: Uninitialized render buffers do not report memory usage correctly
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Jon Buckley
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 15:31 PDT by Jon Buckley
Modified: 2012-07-06 07:57 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test case (217 bytes, text/html)
2012-06-27 15:31 PDT, Jon Buckley
no flags Details
Patch v1 (2.15 KB, patch)
2012-06-27 16:11 PDT, Jon Buckley
jacob.benoit.1: review+
Details | Diff | Review

Description Jon Buckley 2012-06-27 15:31:55 PDT
Created attachment 637286 [details]
test case

I found this while running the WebGL Conformance Tests in a debug build of trunk. If you visit the attached webpage and then visit about:memory, Firefox will always NS_ABORT() when getting the memory usage of unintialized render buffers. This is because it doesn't handle the case where mInternalFormatForGL is null.
Comment 1 Jon Buckley 2012-06-27 16:11:10 PDT
Created attachment 637303 [details] [diff] [review]
Patch v1

Here's a patch that handles the null case for render buffers and textures.

Try server run: https://tbpl.mozilla.org/?tree=Try&rev=09132969a207
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-05 08:14:02 PDT
https://hg.mozilla.org/mozilla-central/rev/74e381773948
Comment 4 Jon Buckley 2012-07-06 07:57:38 PDT
Opening the test case and about:memory in today's Nightly does not cause a crash now.

Note You need to log in before you can comment on or make changes to this bug.