Last Comment Bug 769128 - Ionmonkey default build doesn't use ionmonkey.
: Ionmonkey default build doesn't use ionmonkey.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-27 19:26 PDT by Eric Faust [:efaust]
Modified: 2012-07-11 17:49 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.06 KB, patch)
2012-07-10 08:42 PDT, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Eric Faust [:efaust] 2012-06-27 19:26:26 PDT
As near as I can tell, the ion compiler is not called out to at all, and javascript.options.ion.content seems to have disappeared.
Comment 1 Phil Ringnalda (:philor) 2012-06-27 19:30:23 PDT
The pref went away in https://hg.mozilla.org/projects/ionmonkey/rev/73e8ca73e5bd (where it seemed like odd merge bustage to be fixing, but what do I know?).
Comment 2 Jan de Mooij [:jandem] 2012-07-10 08:42:14 PDT
Created attachment 640614 [details] [diff] [review]
Patch
Comment 3 David Anderson [:dvander] 2012-07-10 19:52:00 PDT
Comment on attachment 640614 [details] [diff] [review]
Patch

Review of attachment 640614 [details] [diff] [review]:
-----------------------------------------------------------------

Okay, it looks like the content pref is still there, the default value was just accidentally removed. Thanks for fixing!
Comment 4 Eric Faust [:efaust] 2012-07-11 17:49:54 PDT
https://hg.mozilla.org/projects/ionmonkey/rev/4335f95a5e42

Note You need to log in before you can comment on or make changes to this bug.