Flash audio from a page that is not open starts playing randomly.

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: Lorne G, Unassigned)

Tracking

({qawanted})

unspecified
x86
Windows XP
qawanted

Firefox Tracking Flags

(firefox14-)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Nothing. During regular use OR idle time.


Actual results:

After a random amount of time greater than approx 10 min the audio from watch.thecomedynetwork.com starts playing without having a tab open with that content. When I check my open tabs none of them have the site up. Only closing the entire browser stops the audio from playing. It has happened consistently since the latest update (13.x).
(Reporter)

Comment 1

6 years ago
After further investigation I found plugin-container.exe running the flash content without having the site open in a tab. Not sure if there are supposed to be multiple plugin-container.exe running at once but there was. Killing plugin-container.exe that was consuming resources killed the mysterious playback
Was the tab previously open and closed at some point during the session? Also, what version of Flash do you have installed?

CCing Alex Keybl:
Alex, didn't we have reports of similar issues sometime ago? I seem to recall trying to investigate a similar issue and we got nowhere with it. Is there something we can ask Lorne to do to help us investigate?
Component: Untriaged → Flash (Adobe)
Product: Firefox → Plugins
QA Contact: untriaged → adobe-flash
Version: 13 Branch → unspecified

Comment 3

6 years ago
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Alex, didn't we have reports of similar issues sometime ago? I seem to
> recall trying to investigate a similar issue and we got nowhere with it. Is
> there something we can ask Lorne to do to help us investigate?

Yeah - bug 757262. Including roc/bsmedberg to help once we have more info, and Cheng to see if this is still a common problem coming up in input.

Also adding qawanted to do some testing around watch.thecomedynetwork.com.
Blocks: 757262
tracking-firefox14: --- → +
Keywords: qawanted

Comment 4

6 years ago
(In reply to Lorne G from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101
> Firefox/13.0.1
> Build ID: 20120614114901
> 
> Steps to reproduce:
> 
> Nothing. During regular use OR idle time.
> 
> 
> Actual results:
> 
> After a random amount of time greater than approx 10 min the audio from
> watch.thecomedynetwork.com starts playing without having a tab open with
> that content. When I check my open tabs none of them have the site up. Only
> closing the entire browser stops the audio from playing. It has happened
> consistently since the latest update (13.x).

Lorne - what version of Flash are you using? Can you check in about:support? Thanks for reporting this.
(In reply to Alex Keybl [:akeybl] from comment #3)
> Also adding qawanted to do some testing around watch.thecomedynetwork.com.

Note, this will require someone in the US to test since this is geo-blocked in Canada.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #5)
> (In reply to Alex Keybl [:akeybl] from comment #3)
> > Also adding qawanted to do some testing around watch.thecomedynetwork.com.
> 
> Note, this will require someone in the US to test since this is geo-blocked
> in Canada.

Actually, I take that back. Comedy Network is the Canadian version, Comedy Central is the US version. Let me see if I can test this.
Just doing the basic test so far with Firefox 13.0.1...

Watched some videos on thecomedynetwork.com, closed the tabs and am now doing my day-to-day browsing. An hour in and no unexpected audio playback so far.
Forgot to mention, I have Flash 11.3.330.262 installed.
Cheng was able to scan support.mozilla.org and only found two recent instances of this being reported.

* https://input.mozilla.org/opinion/3047137 suggests this is no longer reproducible with Firefox 14.0
* https://input.mozilla.org/en-US/opinion/2991033 is the most recent Firefox 14 report (June 9)
* https://input.mozilla.org/en-US/opinion/3007484 is the most recent Firefox 13 report (June 14)

Lorne, can you see if this is reproducible for you with the latest Firefox 14 Beta?
http://beta.mozilla.org
(Reporter)

Comment 10

6 years ago
OS = WinXP 32bit
Flash Version: 11.3.300.262

I'm running a test now. It appears that it only happens after I watch the site and then close the tab.

Updated

6 years ago
Version: unspecified → 13.x
Cannot reproduce on Win XP x86 and Win 7 64-bit on FF 13.0.1 and FF 14b11.
I don't think we've had enough reports of this to be worried about it for FF14's release. Untracking
tracking-firefox14: + → -
(Reporter)

Comment 13

6 years ago
I did some more testing in v13.0.1 and found that the playback was not started by a span of time but rather by visiting another site that has a flash video player on it. I just loaded a site with flash video on it and I can hear Tosh.0 in the background without having a corresponding tab open. I have one instance of plugin-container.exe running @ avg 3% but no tabs with flash content running.

Can I run ff 14b side by side with stable. I don't want to break my extensions?
You can run two Firefox's side-by-side but you can't run the same profile. 

firefox.exe -P -no-remote
(Reporter)

Comment 15

6 years ago
I have updated to firefox 14.0.1. I just opened my browser for the first time today and The Daily Show can be heard playing in the background. No tab open. I do use tree style tabs and have 5 tabs protected and locked non of which are the comedy network site. (gmail, gmail, google calendar, producteev, toggl). This time the audio started playing almost immediately after opening the browser.

It's always http://watch.thecomedynetwork.ca/ that plays. It's like it loads the page and plays whatever video is at the top of the queue on the site.

Here is a list of my installed extensions just in case:

Add Bookmark Here ²
BetterPrivacy
Certificate Patrol
Cookie Monster
Download Statusbar
DownThemAll!
DownThemAll! AntiContainer
Evernote Web Clipper
FEBE
Firebug
FireGestures
FlashGot
Google Shortcuts
HTTPS-Everywhere
LastPass
NoScript
OPIE
Speed Dial
sslpersonas
Tab Mix Plus
Table2Clipboard
Tree Style Tab
Web Developer
Xmarks
avast! WebRep
Java Console
Java Quick Starter
Microsoft .NET Framework Assistant
That's quite the list of extensions. Can you please try this on a new profile with no extensions installed for a few days?
(Reporter)

Comment 17

6 years ago
Instead of running a clean profile I'm going to experiment by disabling one addon at a time and see if I can find an offender.
(Reporter)

Comment 18

6 years ago
Hey guys/gals I figured it out. I use speed dial and have the comedy network as one of my dials. The playback is triggered ever time the dial refreshes the thumbnail by loading the page in the background. mystery solved.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Updated

6 years ago
Resolution: INVALID → WORKSFORME

Comment 19

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 13.x → unspecified
You need to log in before you can comment on or make changes to this bug.