Closed Bug 769183 Opened 10 years ago Closed 4 years ago

There is no way to add new CA certificates to the cert store

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:-)

RESOLVED WONTFIX
blocking-basecamp -

People

(Reporter: amac, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Try to access an internal (intranet) HTTPs site, signed with a corporate (private) PKI


Actual results:

The browser gives an error and stops


Expected results:

It should say the CA is invalid and point to some way to install it if its needed (not necessarily through the browser though)
Blocks: browser-api
blocking-basecamp: --- → ?
Is this in the v1 designs?
I do not think we have capacity to do this in time for any of the deadlines that have been set.
This is not a required capability for v1. Not blocking.
blocking-basecamp: ? → -
Fennec cannot do this either, unless you use a third-party extension.
Not blocking basecamp, moving to a different tracking bug.
Blocks: 775293
No longer blocks: basecamp-security
This was fixed on bug 846734, marking this one as duplicated.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 846734
(In reply to Antonio Manuel Amaya Calvo from comment #6)
> This was fixed on bug 846734, marking this one as duplicated.

Bug 846734 is about cert error exceptions, not importing new root certs, right? This bug seems to be about importing new root certs, which is a different problem. Let me know if I am missing something.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Yes and no. The problem for which I opened is bug originally was e one solved on bug 846734, which is that you could not navigate to any site that was not signed with an existing CA. That's already been fixed. And I didn't retread my own title :). We can leave this open then for a way to add CA certificates instead of granting access on a site by site basis.
Depends on: 867899
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 9 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.