Closed Bug 769218 Opened 8 years ago Closed 8 years ago

Test failure 'Disconnect Error: Application unexpectedly closed' in testGetMoreSearchEngines.js

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: whimboo, Assigned: whimboo)

References

()

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(1 file)

This test failure happens for Nightly and ESR builds on the Windows Vista machine. I would assume that it is similar to bug 767820 and we could fix it by making the testcase local.

Remus, would you mind analyzing the test and trying to create a search engine we can use locally? We should also upload this engine to litmus-data.
We cannot run a search engine locally because we need to have the absolute path to the file and I think we can only access it by http. We can try using the file on mozqa.com.
We'll try to reproduce this with the system under load (using a Pi calculator).
(In reply to Remus Pop (:RemusPop) from comment #1)
> We cannot run a search engine locally because we need to have the absolute
> path to the file and I think we can only access it by http. We can try using

Why do you need the absolute path?
Attached patch Patch v1 (skip)Splinter Review
Anthony, please land this patch across all branches if its ok. Thanks!
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Attachment #637893 - Flags: review?(anthony.s.hughes)
Comment on attachment 637893 [details] [diff] [review]
Patch v1 (skip)

Anthony is out today. So Jeff, we have to disable this test because it is constanly failing on one of our boxes. We have to find a fix first which will take at least 2 or 3 days. Thanks.
Attachment #637893 - Flags: review?(anthony.s.hughes) → review?(jhammel)
Attachment #637893 - Flags: review?(jhammel) → review+
Pushed skip patch across branches:
http://hg.mozilla.org/qa/mozmill-tests/rev/2cc6996a636a (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/417795beed76 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/33322d597b0f (beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/642a492b13a1 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/f2e5f6d61a02 (esr10)

Remus, can you please disable the mozmill flag for the appropriate Litmus tests? Thanks. I will try to get this fixed on Monday.
Flags: in-litmus?(remus.pop)
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
This test was only failing on our Windows Vista machine. I have replaced it with a fresh copy and backed-out this skip patch on default. Lets see if we still get failures today.

http://hg.mozilla.org/qa/mozmill-tests/rev/32421e34b8d8
Disabled litmus ids: 55695, 64049, 15702, 40800.
Flags: in-litmus?(remus.pop) → in-litmus-
This failure didn't happen today:
http://mozmill-ci.blargon7.com/#/functional/report/4c461f9adf1253771fc6455667051b72

I would kinda like to wait for tomorrows results until enabling the tests again on the other branches.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Remus, can you please re-enable the Litmus tests by tomorrow? I would like to wait for some more results on the other branches.
Flags: in-litmus- → in-litmus?(remus.pop)
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure]
Enabled litmus tests: 55695, 64049, 15702, 40800.
Flags: in-litmus?(remus.pop) → in-litmus+
I can now see this application disconnect problem on the broken vista machine I copied locally yesterday. I assume it's also related to bug 770821 but I will have to check.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
The page which gets opened by the IMDB search is:
http://www.imdb.com/find?q=firefox&sourceid=mozilla-search

It contains a Flash object which causes the freeze of Firefox and an application disconnect after a minute.

So we can wait for bug 770821 or make the test local so we do not touch external content with a Flash object embedded.
Status: REOPENED → ASSIGNED
Depends on: 770821
Depends on: 774595
No longer depends on: 770821
Now with Mozmill 1.5.14 released this issue should not happen anymore.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.