Last Comment Bug 769242 - Rename nsDisplaySVG to nsDisplayOuterSVG in preparation for adding other SVG display list item types
: Rename nsDisplaySVG to nsDisplayOuterSVG in preparation for adding other SVG ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-06-28 06:39 PDT by Jonathan Watt [:jwatt]
Modified: 2012-06-30 17:44 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.97 KB, patch)
2012-06-28 06:46 PDT, Jonathan Watt [:jwatt]
dholbert: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-06-28 06:39:46 PDT
This patch renames nsDisplaySVG to nsDisplayOuterSVG in preparation for adding other SVG display list item types in bug 641732.
Comment 1 Jonathan Watt [:jwatt] 2012-06-28 06:46:13 PDT
Created attachment 637497 [details] [diff] [review]
patch
Comment 2 Daniel Holbert [:dholbert] 2012-06-28 10:49:31 PDT
Comment on attachment 637497 [details] [diff] [review]
patch

Stealing review.

>diff --git a/layout/svg/base/src/nsSVGOuterSVGFrame.cpp b/layout/svg/base/src/nsSVGOuterSVGFrame.cpp
>-class nsDisplaySVG : public nsDisplayItem {
>+class nsDisplayOuterSVG : public nsDisplayItem {
> public:
>-  nsDisplaySVG(nsDisplayListBuilder* aBuilder,
>+  nsDisplayOuterSVG(nsDisplayListBuilder* aBuilder,
>                nsSVGOuterSVGFrame* aFrame) :

That last line wants some indentation fixup.

Otherwise looks good -- r=me
Comment 4 Ed Morley [:emorley] 2012-06-29 00:47:09 PDT
https://hg.mozilla.org/mozilla-central/rev/d8308e2677f9

Note You need to log in before you can comment on or make changes to this bug.