Last Comment Bug 769529 - Update nsIWebSocket*.idl comments to reflect that we don't always call OnStart
: Update nsIWebSocket*.idl comments to reflect that we don't always call OnStart
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: WebSockets (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla16
Assigned To: Jason Duell [:jduell] (needinfo me)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-28 20:10 PDT by Jason Duell [:jduell] (needinfo me)
Modified: 2012-10-03 07:32 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
comment-only fix to IDLs (2.66 KB, patch)
2012-06-28 20:10 PDT, Jason Duell [:jduell] (needinfo me)
mcmanus: review+
cbiesinger: superreview+
Details | Diff | Splinter Review

Description Jason Duell [:jduell] (needinfo me) 2012-06-28 20:10:30 PDT
Created attachment 637770 [details] [diff] [review]
comment-only fix to IDLs

We don't always call OnStart, and it's fine IMO.  Websockets are a different animal, and using OnStart only when we've successfully established a connection I think is the right semantic.  But we could wrangle things otherwise if folks feel strongly that making this look more like nsIRequestObserver is important.

Asking biesi for sr, since this is an IDL issue, so I guess might merit sr.  There's no code changes, though, and this is not an IDL that AddOns will ever target, so I'm not sure we really need it.
Comment 1 Jason Duell [:jduell] (needinfo me) 2012-06-29 23:08:53 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/5c76f0b5100a
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-06-30 12:41:55 PDT
https://hg.mozilla.org/mozilla-central/rev/5c76f0b5100a

Note You need to log in before you can comment on or make changes to this bug.