Intermittent TEST-UNEXPECTED-FAIL | test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | undefined == 304

RESOLVED FIXED in Firefox 16

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: briansmith, Assigned: michal)

Tracking

({intermittent-failure, regression})

Trunk
mozilla17
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox16 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | running event loop

TEST-INFO | (xpcshell/head.js) | test 2 pending
TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | Starting test_unexpected_304

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-PASS | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/head_channels.js | [null : 147] 0 == 0

TEST-PASS | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | [consume304 : 53] 304 == 304

TEST-PASS | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | [consume304 : 54] 1 == 1

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | test 2 pending
TEST-INFO | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | Starting test_304_stored_in_cache

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-PASS | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/head_channels.js | [null : 147] 0 == 0

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | undefined == 304 - See following stack:
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 440
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/head.js :: _do_check_eq :: line 534
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/head.js :: do_check_eq :: line 555
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js :: consume304 :: line 53
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/head_channels.js :: <TOP_LEVEL> :: line 152

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/head_channels.js | Error in closure function: 2147500036 - See following stack:
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/head.js :: do_throw :: line 440
JS frame :: /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/head_channels.js :: <TOP_LEVEL> :: line 154

TEST-INFO | (xpcshell/head.js) | exiting test
Failed on Windows opt and OS X opt so far.
OS: Windows 7 → All
Hardware: x86_64 → All
Summary: Intermittent TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | undefined == 304 → Intermittent TEST-UNEXPECTED-FAIL | test/build/xpcshell/tests/netwerk/test/unit/test_304_responses.js | undefined == 304
Blocks: 438871
OS: All → Windows 7
Hardware: All → x86_64
Looks like this is going to be a source of a lot of random orange so it should be fixed soon.
Target Milestone: --- → mozilla16
This is the #3 top orange for the last 7 days. Do you have any ideas about it? :-)
Posted patch fix (obsolete) — Splinter Review
I don't know exactly why, but sometimes request needs to be QI'd to nsIHttpChannel.
Assignee: bsmith → michal.novotny
Attachment #642807 - Flags: review?(bsmith)
Comment on attachment 642807 [details] [diff] [review]
fix

Review of attachment 642807 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for figuring this out.

Please flag for review again if you think my suggestion is not good.

::: netwerk/test/unit/test_304_responses.js
@@ +50,5 @@
>  }
>  
>  function consume304(request, buffer) {
> +  if (!(request instanceof Components.interfaces.nsIHttpChannel))
> +    do_throw("Expecting an HTTP channel");

This should be just request.QueryInterface(ci.nsIHttpChannel), right?

If we need to do a QueryInterface, it is better to just do it directly instead of relying on instanceof to do an implicit QueryInterface.
Attachment #642807 - Flags: review?(bsmith) → review+
https://hg.mozilla.org/mozilla-central/rev/0d798b0f2a62
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: mozilla16 → mozilla17
Please may this be uplifted to aurora too? :-)
Comment on attachment 643173 [details] [diff] [review]
patch v2 - QI instead of instanceof, r=bsmith

Review of attachment 643173 [details] [diff] [review]:
-----------------------------------------------------------------

This is a one-line, **test-only** fix that will reduce noise on the Aurora TBPL.
Attachment #643173 - Flags: approval-mozilla-aurora?
Attachment #643173 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.