Last Comment Bug 769612 - Move the SVGAutoRenderState::SetPaintingToWindow() call to nsDisplayOuterSVG::Paint and kill nsSVGOuterSVGFrame::Paint
: Move the SVGAutoRenderState::SetPaintingToWindow() call to nsDisplayOuterSVG:...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
Mentors:
Depends on:
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-06-29 04:31 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-07-05 17:19 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.60 KB, patch)
2012-06-29 04:31 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-06-29 04:31:02 PDT
Meh. After the patches for bug 732429 and bug 769306, it turns out (bug 769593 comment 6) that I also need the SVGAutoRenderState::SetPaintingToWindow() call when painting SVG using display lists. If I'm moving that to nsDisplayOuterSVG::Paint, then nsSVGOuterSVGFrame::Paint becomes pretty much pointless and we might as well kill it.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-06-29 04:31:53 PDT
Created attachment 637847 [details] [diff] [review]
patch
Comment 2 Robert Longson 2012-06-29 04:41:34 PDT
Comment on attachment 637847 [details] [diff] [review]
patch

stealing
Comment 3 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-05 08:19:31 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/0af1dcf636d7
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-05 17:19:35 PDT
https://hg.mozilla.org/mozilla-central/rev/0af1dcf636d7

Note You need to log in before you can comment on or make changes to this bug.