Closed Bug 769709 Opened 8 years ago Closed 7 years ago

context menu problem with iframes

Categories

(Add-on SDK Graveyard :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: canuckistani, Assigned: mossop)

References

Details

(Whiteboard: [jpcontextmenu])

Builder example: https://builder.addons.mozilla.org/addon/1061187/latest/

To reproduce:

1. load this page: http://www.historyworld.net/textonly/printpg.asp?type=histories&pid=hav&nid=aa61&pcount=5

2. enable the add-on. 
3. select text on the main historyworld page ( it is actually a frame ), right click. You'll see the 'Blah Blah Blah' item in the menu.
4. hit refresh on the historyworld page, then right-click. The context menu item is gone.

Reported by @peced:

https://twitter.com/peced/status/218515992698044417
It shows up again if you right-click in the page, then go into the "This frame" submenu and reload the frame.
> Reported by @peced:
> 
> https://twitter.com/peced/status/218515992698044417

First reported (and first caught) by antelope:

https://addons.mozilla.org/en-US/firefox/addon/prostetnic/reviews/user:6276603

Also fails on Ubuntu 11.10 w. Linux 3.2.7 (my setup).  Don't know what antelope is using.

Best guess is that selectionContext() is not firing.
> Also fails on Ubuntu 11.10 w. Linux 3.2.7 (my setup).  

& Firefox 13.0.1

> Best guess is that selectionContext() is not firing.

My best guess, that is :)
(In reply to Wes Kocher (:KWierso) from comment #1)
> It shows up again if you right-click in the page, then go into the "This
> frame" submenu and reload the frame.

Yeah, but that's cheating.
Cool, thanks for adding the additional info. We'll triage this bug this week but IMO it's pretty obvious breakage.

Wes, I feel like we should have a 'context-menu-sucks' whiteboard or something.
(In reply to Jeff Griffiths from comment #5)
> Wes, I feel like we should have a 'context-menu-sucks' whiteboard or
> something.

Sure.
Whiteboard: [jpcontextmenu]
Can we test this with the fix for the Gmail fix landed?
Depends on: 665386
It looks like it maybe caused by the same iframe hide / show reasons as bug 665386.
So likely not the same fix, Matteo can you take a look at this please?
Assignee: nobody → zer0
Whiteboard: [jpcontextmenu] → [triage:followup][jpcontextmenu]
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86 → All
Whiteboard: [triage:followup][jpcontextmenu] → [jpcontextmenu]
I think the bug 664386 fixed that, I'm not able to reproduce this behavior.

Jeff, could you confirm that is gone?
I don't see any interaction on code side between context-menu module and selection module (I thought that `context-menu` uses `selection` for the `SelectionContext` at least, but it's doing that manually), so likely the bug 665386 is not related. However, I'm not able to reproduce the behavior described by this bug on Firefox 14.0.1. Jeff, could you confirm as well? Otherwise we'll try to understand where is the difference (maybe I'm doing something wrong in order to reproduce it).
Depends on: 788324
I can reproduce this with https://addons.mozilla.org/en-US/firefox/addon/prostetnic/, having difficulty getting a simplified testcase though
I will try this add-on and see if I can reproduce the bug. If I can, I will debug the add-on to find the reason and/or create a simplest testcase.

Mossop, this issue is still present in your new context-menu module?
(In reply to Matteo Ferretti [:matteo] [:zer0] from comment #14)
> I will try this add-on and see if I can reproduce the bug. If I can, I will
> debug the add-on to find the reason and/or create a simplest testcase.
> 
> Mossop, this issue is still present in your new context-menu module?

Until we have add-on source to build against I can't really tell. I attempted to hand-repack the XPI with the latest SDK and couldn't reproduce it there so it's possible it's even already fixed in master, but it's also possible I was just doing it wrong.
I did a little more digging and I can now reproduce this with a very simple testcase, but only in my normal Firefox profile. In a clean profile the problem vanishes so there is something profile specific going on here which might explain why some people see it and some don't
And the good news is that it does go away with my context-menu rewrite, the challenge is going to be figuring out how to test it since it's profile specific
Assignee: zer0 → dtownsend+bugmail
Status: NEW → ASSIGNED
Fixed by bug 788324
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.13
You need to log in before you can comment on or make changes to this bug.