Last Comment Bug 769743 - simplify ScopedCoordinate::slot and fix names
: simplify ScopedCoordinate::slot and fix names
Status: RESOLVED FIXED
[js:t]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Luke Wagner [:luke]
:
Mentors:
Depends on: 770102 778467
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 11:46 PDT by Luke Wagner [:luke]
Modified: 2012-07-28 11:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (36.39 KB, patch)
2012-06-29 11:46 PDT, Luke Wagner [:luke]
dvander: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-06-29 11:46:38 PDT
Created attachment 637953 [details] [diff] [review]
patch

ScopeCoordinate::slot isn't really the scope object slot, it's some sort of abstract index.  It should be the slot (esp. with bug 767013).

This patch also simplifies the conversions between frame-relative indices and scope-object-relative indices.  The comment in jsscript.h should explain.

Flagging dvander for review since this should require some minor tweaks in IM when this merges.
Comment 1 Luke Wagner [:luke] 2012-06-29 16:28:53 PDT
Thanks for the quick review!

https://hg.mozilla.org/integration/mozilla-inbound/rev/e8bab55ac425
Comment 2 Phil Ringnalda (:philor) 2012-06-29 19:10:31 PDT
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/df25da024956 - it was a little bit short of actually compiling.
Comment 3 Phil Ringnalda (:philor) 2012-06-29 19:11:38 PDT
s/compiling/compiling for 32-bit/
Comment 4 Luke Wagner [:luke] 2012-06-29 19:30:35 PDT
Arg; the cursed JS_STATIC_ASSERT(sizeof(JSScript) % sizeof(Value) == 0).

https://hg.mozilla.org/integration/mozilla-inbound/rev/0d9f7fb55226
Comment 5 Jeff Walden [:Waldo] (remove +bmo to email) 2012-06-30 00:31:25 PDT
Now the no-methodjit shell builds are burning (#winning):

https://tbpl.mozilla.org/?tree=Mozilla-Inbound&noignore=1&jobname=spidermonkey
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-06-30 12:42:43 PDT
https://hg.mozilla.org/mozilla-central/rev/0d9f7fb55226
Comment 7 Ryan VanderMeulen [:RyanVM] 2012-07-02 19:01:08 PDT
https://hg.mozilla.org/mozilla-central/rev/3b86df322556

Note You need to log in before you can comment on or make changes to this bug.