Last Comment Bug 769785 - Settings API breaks due to IndexedDB Prefix change
: Settings API breaks due to IndexedDB Prefix change
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Kyle Machulis [:kmachulis] [:qdot]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-29 13:19 PDT by Kyle Machulis [:kmachulis] [:qdot]
Modified: 2012-06-29 19:22 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
V1: Settings API breaks due to IndexedDB Prefix change (1.28 KB, patch)
2012-06-29 13:34 PDT, Kyle Machulis [:kmachulis] [:qdot]
khuey: review+
Details | Diff | Review

Description Kyle Machulis [:kmachulis] [:qdot] 2012-06-29 13:19:25 PDT
As of http://hg.mozilla.org/mozilla-central/rev/8f307e676f32, nsIDBObjectStore.getAll() is now nsIDBObjectStore.mozGetAll(). This causes API breakage in dom/settings/SettingsManager.js and dom/settings/SettingsService.js, which in turn causes gaia to not be able to load apps.
Comment 1 Kyle Machulis [:kmachulis] [:qdot] 2012-06-29 13:34:51 PDT
Created attachment 637994 [details] [diff] [review]
V1: Settings API breaks due to IndexedDB Prefix change
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-29 13:38:04 PDT
Comment on attachment 637994 [details] [diff] [review]
V1: Settings API breaks due to IndexedDB Prefix change

Review of attachment 637994 [details] [diff] [review]:
-----------------------------------------------------------------

mumble tests mumble
Comment 3 Kyle Machulis [:kmachulis] [:qdot] 2012-06-29 13:59:25 PDT
http://hg.mozilla.org/mozilla-central/rev/a12b54b2f848
Comment 4 Gregor Wagner [:gwagner] 2012-06-29 17:07:50 PDT
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> Comment on attachment 637994 [details] [diff] [review]
> V1: Settings API breaks due to IndexedDB Prefix change
> 
> Review of attachment 637994 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> mumble tests mumble

We have tests but they are not enabled on desktop. Maybe we should do that.
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-29 19:22:57 PDT
Yes please!

Note You need to log in before you can comment on or make changes to this bug.