If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Signaling code needs separate build for linking with C++ tests.

RESOLVED DUPLICATE of bug 792188

Status

()

Core
WebRTC: Signaling
RESOLVED DUPLICATE of bug 792188
5 years ago
5 years ago

People

(Reporter: ehugg, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WebRTC], [blocking-webrtc-])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Signaling code needs to be built twice.  Once for inclusion is the browser and differently for the test harness.  In particular MOZILLA_INTERNAL_API should only  be defined in the first case.
(Reporter)

Comment 1

5 years ago
Created attachment 638021 [details] [diff] [review]
Build signaling twice for FF and Test
(Reporter)

Comment 2

5 years ago
Here's the patch that should make signaling twice.

The makes differ by the define of MOZILLA_INTERNAL_API:
ehugg@ehugg-linux:~/mozilla/alder/alder/obj-x86_64-unknown-linux-gnu/media/webrtc$ grep INTERNAL signaling/signaling_ecc/Makefile 
  -DMOZILLA_INTERNAL_API \
  -DMOZILLA_INTERNAL_API \
ehugg@ehugg-linux:~/mozilla/alder/alder/obj-x86_64-unknown-linux-gnu/media/webrtc$ grep INTERNAL signalingtest/signaling_ecc/Makefile 
ehugg@ehugg-linux:~/mozilla/alder/alder/obj-x86_64-unknown-linux-gnu/media/webrtc$ 

Which makes the objs differ like this:
ehugg@ehugg-linux:~/mozilla/alder/alder/obj-x86_64-unknown-linux-gnu/media/webrtc$ nm signaling/signaling_ecc/src/peerconnection/PeerConnectionImpl.o | grep NS_DebugBreak
                 U NS_DebugBreak_P
ehugg@ehugg-linux:~/mozilla/alder/alder/obj-x86_64-unknown-linux-gnu/media/webrtc$ nm signalingtest/signaling_ecc/src/peerconnection/PeerConnectionImpl.o | grep NS_DebugBreak
                 U NS_DebugBreak


f=EKR - to check if this give what we need
f=RJesup - to check if this is the best way to do this.
(Reporter)

Updated

5 years ago
Attachment #638021 - Flags: feedback?(rjesup)
Attachment #638021 - Flags: feedback?(ekr)

Updated

5 years ago
Attachment #638021 - Flags: review+
Comment on attachment 638021 [details] [diff] [review]
Build signaling twice for FF and Test

+        ['build_for_test==1', {
+          'defines' : [
+          ],
+        }], 

This doesn't do anything; remove.
Attachment #638021 - Flags: feedback?(rjesup) → feedback+

Comment 4

5 years ago
Funny you should mention that, since I just added a clause here.

Updated

5 years ago
QA Contact: jsmith

Updated

5 years ago
Whiteboard: [WebRTC], [blocking-webrtc-]

Updated

5 years ago
Attachment #638021 - Flags: feedback?(ekr)
(Reporter)

Comment 5

5 years ago
This was put into M-C as part of the Alder merge - Bug 792188
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 792188
You need to log in before you can comment on or make changes to this bug.