Last Comment Bug 769810 - Mac ATI OpenGL driver still needs math function emulation on 10.8
: Mac ATI OpenGL driver still needs math function emulation on 10.8
Status: RESOLVED FIXED
webgl-conformance
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Nobody; OK to take it and work on it
: Benoit Jacob [:bjacob] (mostly away)
Mentors:
Depends on:
Blocks: 735560
  Show dependency treegraph
 
Reported: 2012-06-29 14:01 PDT by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-07-05 17:19 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
enable math function emulation on all OSX versions (913 bytes, patch)
2012-06-29 14:01 PDT, Benoit Jacob [:bjacob] (mostly away)
jgilbert: review+
Details | Diff | Review

Description Benoit Jacob [:bjacob] (mostly away) 2012-06-29 14:01:47 PDT
Created attachment 638005 [details] [diff] [review]
enable math function emulation on all OSX versions

In bug 665578 we enabled ANGLE math function emulation to work around Mac ATI OpenGL driver bugs, but only on Mac OS 10.6. We wanted to be aggressive about avoiding this workaround on newer Mac versions because of issues in the ANGLE math function emulation at the time. Now these ANGLE issues seem to have long been fixed and also, we now know that this is still needed on 10.8 to pass the remaining failing GLSL conformance tests.
Comment 1 Jeff Gilbert [:jgilbert] 2012-07-02 11:50:00 PDT
Comment on attachment 638005 [details] [diff] [review]
enable math function emulation on all OSX versions

Review of attachment 638005 [details] [diff] [review]:
-----------------------------------------------------------------

Can you add a comment pointing to this bug also, since we already have a comment pointing to a bug here?
Comment 2 Benoit Jacob [:bjacob] (mostly away) 2012-07-04 16:13:30 PDT
Part of this tryserver push: https://tbpl.mozilla.org/?tree=Try&rev=35d614a1c367
Comment 3 Benoit Jacob [:bjacob] (mostly away) 2012-07-05 07:20:28 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/89b620627911
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-05 17:19:57 PDT
https://hg.mozilla.org/mozilla-central/rev/89b620627911

Note You need to log in before you can comment on or make changes to this bug.