Last Comment Bug 769902 - Avoid unnecessary precision issues in nsSVGUtils::ObjectSpace
: Avoid unnecessary precision issues in nsSVGUtils::ObjectSpace
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-06-30 03:00 PDT by Jonathan Watt [:jwatt]
Modified: 2013-03-08 11:25 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.56 KB, patch)
2012-06-30 03:01 PDT, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] 2012-06-30 03:00:44 PDT
One of the causes of failure in bug 614732 is a precision issue in nsSVGUtils::ObjectSpace, causing us to round in the wrong direction under the wrong set of circumstances. The upcoming patch fixes that.
Comment 1 Jonathan Watt [:jwatt] 2012-06-30 03:01:43 PDT
Created attachment 638091 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] 2012-06-30 13:22:18 PDT
Pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/38c2df3ae405
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-01 08:36:12 PDT
https://hg.mozilla.org/mozilla-central/rev/38c2df3ae405

Note You need to log in before you can comment on or make changes to this bug.