Last Comment Bug 769970 - Get SVG patterns working under HTML elements with CSS transforms applied
: Get SVG patterns working under HTML elements with CSS transforms applied
Status: RESOLVED FIXED
: perf
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt] (back in October - email directly if necessary)
:
Mentors:
Depends on:
Blocks: 614732
  Show dependency treegraph
 
Reported: 2012-06-30 17:15 PDT by Jonathan Watt [:jwatt] (back in October - email directly if necessary)
Modified: 2012-07-14 10:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (19.88 KB, patch)
2012-07-13 06:53 PDT, Jonathan Watt [:jwatt] (back in October - email directly if necessary)
roc: review+
Details | Diff | Splinter Review

Description Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-06-30 17:15:53 PDT
Along the lines of bug 769103, SVG patterns don't account for transforms that are already applied to the gfxContext that is being painting to. For elements that are under a CSS transform that's scales the element up, this means that we create surfaces that are too small (or, more to the point, surfaces that don't have enough resolution) when creating patterns. As a result, the more the element is scaled up, the more pixelated the pattern becomes.

This isn't generally a problem for SVG, since the transforms aren't accumulated on the gfxMatrix as we descend down the tree. However, when switching to display list painting of SVG, we do accumulate the transforms as we descend the tree, and this bug causes various SVG reftests to fail.
Comment 1 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-13 06:53:02 PDT
Created attachment 641854 [details] [diff] [review]
patch
Comment 2 Jonathan Watt [:jwatt] (back in October - email directly if necessary) 2012-07-13 16:19:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b489e06d3874
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-07-14 10:03:28 PDT
https://hg.mozilla.org/mozilla-central/rev/b489e06d3874

Note You need to log in before you can comment on or make changes to this bug.