Note: There are a few cases of duplicates in user autocompletion which are being worked on.
Bug 770005 (mathml-fonts-mac)

Make a Mac OS X Installer for MathML fonts

RESOLVED WONTFIX

Status

()

Core
MathML
P5
enhancement
RESOLVED WONTFIX
5 years ago
3 years ago

People

(Reporter: fredw, Assigned: Mahmut Bulut)

Tracking

(Blocks: 1 bug)

Trunk
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
This is the counterpart of bug 767725, but for Mac OS X. Apparently, the standard procedure on Mac OS X is to use *.pkg file. The fonts to install are:

- STIX fonts
- MathJax fonts
- Asana Math

It seems that STIX are now installed by default on Mac OS X Lion, so the issue is less serious than the Windows' one. But still, it may be convenient to have such an installer.

I don't really know about a lot about Mac OS X, but I will be happy to help anyone willing to work on this.
(Assignee)

Comment 1

5 years ago
I can prepare a package for Mac, but I need requirements for package. Can you inform me about this requirements?
(Reporter)

Comment 2

5 years ago
Thanks for your help!

A minimal package would allow to copy font files in a standard location (I guess ~/Library/Fonts/ on Mac). These files are available as a zip archive here:

https://developer.mozilla.org/en-US/docs/Mozilla_MathML_Project/Fonts

STIX fonts are already installed by default on Mac OS X Lion (10.7) and greater, so I guess something can be done to avoid copying the STIX files on these platforms.

Of course, more features could be interesting. As a comparison, the Windows version of this package is able to uninstall the fonts or to let the user choose which fonts to install among STIX, MathJax and Asana. Perhaps in Mac, one would like to be able to choose another standard location too (like /Library/Fonts/).
(Assignee)

Comment 3

5 years ago
Created attachment 669174 [details]
Mozilla MathML Installer Package

Mozilla MathML Installer Package including Uninstaller App
(Reporter)

Comment 4

5 years ago
Thanks Mahmut. I don't know if you are familiar with Mozilla's contribution process, but generally contributors provide changes as "patches" that other Mozilla developers can review and approve:

https://developer.mozilla.org/en-US/docs/Developer_Guide/How_to_Submit_a_Patch

I don't think that the full process is necessary for this bug, but still that would be useful to have some source file or something that allows to generate the *.pkg file. That way, we can verify that your changes are OK and make the file available from one of Mozilla's server. Moreover, that will enable one to regenerate the *.pkg if, for example, we want to add more files. For example, the Windows installer is created from this XML file:

https://github.com/fred-wang/Mathzilla/blob/master/mathml-fonts/MSI/MathML-fonts.wxs

Are you able to provide such a source file for the Mac installer or explain how you generated it? I don't know much about Mac, perhaps this pkg file is an archive and the installation information are already included inside this archive?

I believe I can have access to a Mac and so verify your installer.
Assignee: nobody → mahmutbulut0
Status: NEW → ASSIGNED
(Reporter)

Comment 5

5 years ago
It's a bit difficult to test your installer on a Mac (I use a remote machine), but I've seen that indeed the pkg file is an archive with install information. Did you directly create this archive or did you use a generator from source files?

I tried your installer but it froze and I had to reboot the machine. Also I forgot to mention that the fonts are not created by Mozilla and have other license: "SIL Open Font License" for STIX and Asana and the Apache License for MathJax.
Flags: needinfo?(mahmutbulut0)
(Reporter)

Comment 6

5 years ago
OK, finally I've been able to use the installer. That seems to work (I don't know why it froze last time), but there are three points I'd like to be sure before uploading your package on the MDN site:

1) The fonts are moved to /Library/Fonts/MathML/. Does that work or should the files directly be put in /Library/Fonts/ without an intermediate MathML directory? You can try to install & uninstall several times your package and verify with this test page:

  https://developer.mozilla.org/en-US/docs/Mozilla_MathML_Project/Fonts/Test

 You can test one font at a time by opening "about:config" in Firefox and setting the "font.mathfont-family" option to

  - "MathJax_Main"
  - "STIXNonUnicode, STIXSizeOneSym, STIXGeneral"
  - "Asana Math"

  (Note that the STIX fonts may already be installed on your Mac)
  
2) Add licenses for the font package (comment 5)

3) The source files to generate your installer for review and future updates (comment 4). Note that just as the MathML-fonts.wxs mentioned above, that would be great to have source distributed under MPL 2.0 or other free license.

Some additional remarks:

- Perhaps the user should be able to check an "I agree" box before that the warning popup appears

- I don't know the Mac interface well, but one has to use Finder to uninstall the font package. It seems that other packages have an uninstall option directly integrated in the installer: http://guides.macrumors.com/Uninstalling_Applications_in_Mac_OS_X
(Reporter)

Comment 7

5 years ago
Also, I guess installing in /Library/Fonts/ requires admin privilege. Perhaps there should be an option to install fonts in the user directory ~/Library/Fonts/.
(Assignee)

Comment 8

5 years ago
At First:
I can only provide MacOS PackageMaker project file I have already built it from there.

Second;
I created this archive directly with MacOS PackageMaker Tool.

Third;
I created "MathML" intermediate directory and placed it in main root fs for better usage of fonts. FontBook stores fonts at user level. If it is copied to user level. Other users cannot use this and in addition to this we have no choice about what is user's home directory permissions because we must give strictly the same permissons to font files where it copied.

Fourth;
I have tested and I see perfect grid in your test link.

Fifth;
Already License agreement agree window appears in installer.

Sixth;
If you hoover your mouse to /Applications directory you will see MathML uninstaller.

Sorry for my late response, I was very busy. :)
Flags: needinfo?(mahmutbulut0)
(Assignee)

Comment 9

5 years ago
Created attachment 673331 [details]
Mozilla MathML Fonts project file
(Reporter)

Comment 10

5 years ago
(In reply to Mahmut Bulut from comment #8)
> At First:
> I can only provide MacOS PackageMaker project file I have already built it
> from there.
> 
> Second;
> I created this archive directly with MacOS PackageMaker Tool.

Thanks, that's a shame that the file is not really "readable" for review. But I guess we would still be able to use it if we update the font package later.

> 
> Third;
> I created "MathML" intermediate directory and placed it in main root fs for
> better usage of fonts. FontBook stores fonts at user level. If it is copied
> to user level. Other users cannot use this and in addition to this we have
> no choice about what is user's home directory permissions because we must
> give strictly the same permissons to font files where it copied.
> 

As I indicated above, I'm not a mac expert and don't know what is the usual way to install fonts. It's fine if we only installed it to /Library/Fonts/ I was just trying to suggest you improvements for users without admin rights.

My main concern was really that the fonts did not seem to be used by Firefox when we have this intermediate MathML/ directory (it does when I moved them to the parent directory /Library/Fonts/). See my next remark about how to really test the fonts.

> Fourth;
> I have tested and I see perfect grid in your test link.

As I told you the STIX fonts are already installed on new Mac versions by default, so in that case the test will obviously pass. I would really like to know if that's the case if you uninstall the STIX fonts from your system and use your installer instead ; and use the about:config thing I mentioned above to test each font (not just the STIX ones). Alternatively, you can send me screenshots by mail of

http://www.mozilla.org/projects/mathml/demo/texvsmml.html

and I may tell you which fonts are actually used.

> 
> Fifth;
> Already License agreement agree window appears in installer.

My point was that it is a popup that only appears when you click next. In general people are able to accept the license before seeing such a warning. Again, this was just a suggestion for an improvement, not something too serious.

> 
> Sixth;
> If you hoover your mouse to /Applications directory you will see MathML
> uninstaller.

This was also just a suggestion. Indeed, I realized how to uninstall the fonts, but the link I gave you indicate that there may be other a standard way to do so: integrating an uninstall option in the installer itself. Again I don't know what are Mac best practices.

> 
> Sorry for my late response, I was very busy. :)

No problem and thanks for working on this. So to sum up: I would really be happy to integrate your PackageMaker project files and font installer in Mozilla as long as I'm sure issues 1) 2) and 3) of comment 6 are solved. You can ignore the other suggested improvements.
(Reporter)

Comment 11

5 years ago
BTW, do you know if PackageMaker is installed by default on Mac or should it be downloaded from somewhere?

I guess I can try to open the project files but it seems that they contain absolute paths like /Users/vertexclique/ which are not likely to make it portable.
(Reporter)

Updated

5 years ago
Priority: -- → P5

Comment 12

4 years ago
Can you confirm that you're still working on this bug?
Flags: needinfo?(mahmutbulut0)
(Assignee)

Comment 13

4 years ago
Yes I will do that as soon as possible...
Flags: needinfo?(mahmutbulut0)
(Reporter)

Updated

4 years ago
Depends on: 947654
(Reporter)

Comment 14

3 years ago
For Gecko >= 31, the recommended fonts are available from MacPorts. Also, I've submitted bug reports to Apple. So I'd suggest to close this as WONTFIX.

https://developer.mozilla.org/en-US/docs/Mozilla/MathML_Project/Fonts#Mac
Keywords: helpwanted, regression, student-project
Whiteboard: [mentor=fredw] → [closeme 2014-06-30]

Comment 15

3 years ago
Resolved per whiteboard and Comment 14
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Whiteboard: [closeme 2014-06-30]
You need to log in before you can comment on or make changes to this bug.