GMail Mail Listing (e.g. Inbox) broken

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: xtc4uall, Assigned: Tal Aloni)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 638186 [details]
Screenshot showing the Issue

Compare your GMail Inbox using yesterday's and today's Nightly (see Screenshot).
Likely by Bug 539356, no?

Comment 1

5 years ago
Created attachment 638189 [details]
Comparison  Chrome, Aurora and Nightly

Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/eb8f9356376a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120630083850
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a52d79ad75da
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120630090151
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=eb8f9356376a&tochange=a52d79ad75da

Suspected: Bug 248239

Updated

5 years ago
Blocks: 248239
(Reporter)

Comment 2

5 years ago
Thanks Alice, just was about to Post that correct Regression Window :-)
(Assignee)

Comment 3

5 years ago
Hi all,
Gmail generate a different CSS based on user agent (to work around various bugs / limitations of specific browsers).
[The cells in that row gets height of 2.83ex in IE8 and 3.61ex in Firefox]
In firefox 16 we have fixed bug 248239, and we are now correctly calculating table cell height, however, Gmail does not know that yet and that's why you get the extra padding, hopefully Firefox 16 will get the proper treatment soon.

I know some of you may feel that this is a regression, but this is actually progress, only by fixing those bugs and being compliant with the standard we will be able to advance to the day where a CSS per browser is no longer needed.

Comment 4

5 years ago
(In reply to Tal Aloni from comment #3)
> In firefox 16 we have fixed bug 248239, and we are now correctly calculating
> table cell height, however, Gmail does not know that yet and that's why you
> get the extra padding, hopefully Firefox 16 will get the proper treatment
> soon.

So,this is "Tech Evangelism" Bug?
If so, would someone please contact Gmail developers?
(Assignee)

Comment 5

5 years ago
Already on it:
http://productforums.google.com/forum/#!category-topic/gmail/report-an-issue/9ZN7XwaFsGI

Updated

5 years ago
Keywords: regression

Updated

5 years ago
Assignee: nobody → english-us
Component: Layout → English US
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified

Updated

5 years ago
tracking-firefox16: --- → ?

Comment 6

5 years ago
This also affects the spacing on Google Docs spreadsheets.
(Assignee)

Comment 7

5 years ago
(In reply to rmlipman from comment #6)
> This also affects the spacing on Google Docs spreadsheets.

Thanks, it's already been reported (770045)
Duplicate of this bug: 771126

Comment 9

5 years ago
Although this is in evangelism, I'd actually rather this is assigned to Matt to come up with alternative options if Google doesn't fix in time. Is backing out bug 539356 our only option in that case?
Assignee: english-us → matt.woodrow
tracking-firefox16: ? → +
This wasn't broken by DLBI. It was "broken" by bug 248239 (which just happened to land around the same time).

Updated

5 years ago
Assignee: matt.woodrow → tal.aloni.il
tracking-firefox16: + → ?
Thanks, sending over to Tal in that case with the same motivation (what alternative do we have if Google doesn't fix, back out bug 248239?).
tracking-firefox16: ? → +

Comment 12

5 years ago
Note that bug 338554 (which is a pretty nice bug fix IMHO) depends on bug 248239
The alternative is to back out.  The patch was an intentional behavior change to be more compatible with other browsers and with relevant specs, and which broke sites that were explicitly working around it by behaving differently for Firefox (and Opera).

Backing out may *also* get us into trouble because some of the sites that have updated are probably doing version-based detection (i.e., changing their "work around Firefox bug" JS to be "work around bug in Firefox versions 15 or less" JS).  So if we want to back out we need to do so soon and get people to undo the changes we've gotten them to do.
(Assignee)

Comment 14

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #11)
> Thanks, sending over to Tal in that case with the same motivation.

Guys, with the help of Ehsan Akhgari Google is already in the process of canceling the bug-workaround for the Spreadsheets (See Bug 770045), Which I felt was a higher priority.

After we've made sure Google could resolve that issue successfully (few days according to them), we'll try to get more attention to this issue.
I think you should proceed on this issue without waiting for them to finish fixing the first.
(In reply to David Baron [:dbaron] from comment #15)
> I think you should proceed on this issue without waiting for them to finish
> fixing the first.

Agreed. Tal, please let us know if you need any help on this bug in the short term and we'll get some more eyes on it. We'd really like to get this fixed (externally or in-product) as soon as possible in the Aurora 16 cycle.
(Assignee)

Comment 17

5 years ago
(In reply to Alex Keybl [:akeybl] from comment #16)
> Tal, please let us know if you need any help on this bug in the
> short term and we'll get some more eyes on it.
I've now asked Ehsan Akhgari to use the mozilla-google-discuss list to get more attention to this issue (only Mozilla employees can use it), I hope that would be enough to get this fixed.
I contacted Google about this.
This looks fixed to me now. Maybe it came along with the Docs fix?
(Assignee)

Comment 20

5 years ago
(In reply to Ryan VanderMeulen from comment #19)
> This looks fixed to me now. Maybe it came along with the Docs fix?

The issue is still there, you simply got used to the king-size listing :)
(Assignee)

Comment 21

5 years ago
a quick update:
The Google Apps team canceled the bug-workaround for the Spreadsheets. (Bug 770045)

We still got no response from the Gmail team on the mozilla-google-discuss list,
It would be helpful if any of you have a more direct channel to the Gmail team.

Comment 22

5 years ago
Should the fix be tight to Firefox 16? or to some Gecko version?

Gmail team.
(Assignee)

Comment 23

5 years ago
Awesome!
Should be tied to Gecko 16.

Thanks!
Tal
OK, now it looks like GMail is fixed for real. Almost forgot what it used to look like :P
(In reply to comment #24)
> OK, now it looks like GMail is fixed for real. Almost forgot what it used to
> look like :P

I still experience the bug in my gmail account.
(In reply to Ehsan Akhgari [:ehsan] from comment #25)
> 
> I still experience the bug in my gmail account.

So do I
Just compare with the rendering in Firefox 14 to see that it's way more compact

Comment 27

5 years ago
It looks fixed for me on gmail, but not for my google apps email. It probably just hasn't been rolled out to google apps yet.
(Assignee)

Comment 28

5 years ago
I have tested both Gmail and Google Apps email, both Aurora and Nightly, and I can confirm that the issue is resolved.

Thanks Gmail team!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox16: --- → fixed
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.