Last Comment Bug 770193 - Make it easier to start searching for scripts in the Debugger
: Make it easier to start searching for scripts in the Debugger
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: 12 Branch
: All All
: P3 normal (vote)
: Firefox 17
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on: 775050
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 08:30 PDT by Victor Porof [:vporof][:vp]
Modified: 2012-08-02 04:22 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (1.46 KB, patch)
2012-07-20 06:36 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review
v2 (1.71 KB, patch)
2012-07-27 04:32 PDT, Victor Porof [:vporof][:vp]
rcampbell: review+
Details | Diff | Splinter Review
v2.1 (1.75 KB, patch)
2012-08-01 09:13 PDT, Victor Porof [:vporof][:vp]
no flags Details | Diff | Splinter Review

Description Victor Porof [:vporof][:vp] 2012-07-02 08:30:42 PDT
There's currently no shortcut to focus the searchbox, except for tabbing like crazy or clicking on it. Madness.

We need a command.
Comment 1 Victor Porof [:vporof][:vp] 2012-07-20 06:36:42 PDT
Created attachment 644296 [details] [diff] [review]
v1

The .. annoying thing is that the debugger needs to have focus somehow before the command would work. We can easily get away with this if we set focus to the source editor on load.
Comment 2 Victor Porof [:vporof][:vp] 2012-07-27 04:32:19 PDT
Created attachment 646516 [details] [diff] [review]
v2
Comment 3 Victor Porof [:vporof][:vp] 2012-07-27 04:32:29 PDT
Changed because bug 775050.
Comment 4 Rob Campbell [:rc] (:robcee) 2012-08-01 08:39:39 PDT
Comment on attachment 646516 [details] [diff] [review]
v2

+   * Called when the scripts filter key sequence was presed.

typo: pressed.
Comment 5 Victor Porof [:vporof][:vp] 2012-08-01 09:13:23 PDT
Created attachment 647976 [details] [diff] [review]
v2.1
Comment 6 Victor Porof [:vporof][:vp] 2012-08-01 14:01:15 PDT
https://hg.mozilla.org/integration/fx-team/rev/834a0c1ef40b
Comment 7 Tim Taubert [:ttaubert] (on PTO, back Aug 29th) 2012-08-02 04:22:04 PDT
https://hg.mozilla.org/mozilla-central/rev/834a0c1ef40b

Note You need to log in before you can comment on or make changes to this bug.