Last Comment Bug 770230 - Broken symlinks in webrtc code
: Broken symlinks in webrtc code
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 09:57 PDT by Justin Lebar (not reading bugmail)
Modified: 2012-07-27 10:23 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove broken symlinks to third_party/google-visualization-python (1.52 KB, patch)
2012-07-06 08:41 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
tterribe: review+
Details | Diff | Review

Description Justin Lebar (not reading bugmail) 2012-07-02 09:57:13 PDT
> $ hg locate | xargs head > /dev/null
> head: cannot open `media/webrtc/trunk/tools/python_charts/gviz_api.py' for reading: No such file or directory
> head: cannot open `media/webrtc/trunk/tools/quality_tracking/dashboard/gaeunit.py' for reading: No such file or directory
> head: cannot open `media/webrtc/trunk/tools/quality_tracking/dashboard/gviz_api.py' for reading: No such file or directory
> head: cannot open `media/webrtc/trunk/tools/quality_tracking/oauth2' for reading: No such file or directory

These files are all broken symlinks.  For example

> $ readlink media/webrtc/trunk/tools/python_charts/gviz_api.py
> ../../third_party/google-visualization-python/gviz_api.py
>
> $ hg locate | grep gviz_api.py
> media/webrtc/trunk/tools/python_charts/gviz_api.py
> media/webrtc/trunk/tools/quality_tracking/dashboard/gviz_api.py

Note no third_party directory there.

In general, I thought we couldn't have symlinks in our tree, because Windows does not handle them properly.
Comment 1 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-02 12:13:10 PDT
Thanks.  Since we were importing 3800ish files with 500K lines of source, some things slipped through (and none of my tools flagged it, even in windows builds, since those probably aren't actually needed except maybe for some tests we aren't running).
Comment 2 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 08:41:32 PDT
Created attachment 639690 [details] [diff] [review]
Remove broken symlinks to third_party/google-visualization-python
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 08:55:18 PDT
Comment on attachment 639690 [details] [diff] [review]
Remove broken symlinks to third_party/google-visualization-python

Note that we don't do anything currently with tools/python_charts; if we want to we'll need to import these files.
Comment 4 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 09:16:39 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3477c454d7f3
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-07 12:03:28 PDT
https://hg.mozilla.org/mozilla-central/rev/3477c454d7f3

Note You need to log in before you can comment on or make changes to this bug.