If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Tapping to copy selected text is too hard when the text is small

VERIFIED FIXED in Firefox 15

Status

()

Firefox for Android
Text Selection
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Trunk
Firefox 16
All
Android
Points:
---

Firefox Tracking Flags

(firefox15 verified, firefox16 verified, firefox17 verified)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
To copy text, you have to tap within the selected text.  When the text is fairly small (for example, if the page is zoomed out), it's too easy to tap outside of the selection by accident.  We should add a small margin to the the tappable area to make it easier to hit.
(Assignee)

Comment 1

5 years ago
Created attachment 638537 [details] [diff] [review]
patch

I still need to test this, but I think it'll do the trick.
(Assignee)

Comment 2

5 years ago
Created attachment 638550 [details] [diff] [review]
patch v2
Attachment #638537 - Attachment is obsolete: true
Attachment #638550 - Flags: review?(margaret.leibovic)

Updated

5 years ago
Blocks: 695173

Updated

5 years ago
Attachment #638550 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/166fc54b3964
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/166fc54b3964
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16

Comment 5

5 years ago
Comment on attachment 638550 [details] [diff] [review]
patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): this should be part of the text selection mass uplift (bug 695173), but was fixed after the roll-up patch in that bug was created
User impact if declined: tapping to copy text is too hard
Testing completed (on m-c, etc.): landed on m-c 7/3
Risk to taking this patch (and alternatives if risky): low risk 
String or UUID changes made by this patch: n/a
Attachment #638550 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #638550 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 6

5 years ago
Uplifted to aurora as part of a roll-up patch:
https://hg.mozilla.org/releases/mozilla-aurora/rev/2fb0a358eaf6
status-firefox15: --- → fixed
status-firefox16: --- → fixed
Component: General → Text Selection

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
status-firefox17: --- → verified
You need to log in before you can comment on or make changes to this bug.