The default bug view has changed. See this FAQ.

Crash when changing opacity of multiple nested elements

RESOLVED FIXED in mozilla17

Status

()

Core
Layout
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {crash, regression, testcase})

16 Branch
mozilla17
x86_64
Mac OS X
crash, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 638542 [details]
testcase (crashes Firefox when loaded)

1. Set
  user_pref("layers.acceleration.disabled", true);
2. Load the testcase

Result: Crash!
(Reporter)

Comment 1

5 years ago
Created attachment 638543 [details]
stack trace

Nightly: bp-682a29d6-cfc8-45d8-bca2-616902120703
(Reporter)

Comment 2

5 years ago
I would not be surprised if this were a regression from bug 539356.
Is this a recent regression?
Blocks: 539356

Updated

5 years ago
Keywords: regression
Version: Trunk → 16 Branch
Doesn't crash here.
(Reporter)

Comment 5

5 years ago
Probably because bug 539356 was backed out.
Can you check this is, Jesse?
Reason being that Matt wants tests for as many of the regressions from the DLBI bug in the tree as possible, so that Try will pick up failures before he pushes to m-i.
(Reporter)

Comment 8

5 years ago
I could add it as a crashtest, but that might not cause it to run with layers.acceleration.disabled.
Some of our tinderbox test machines have layers acceleration disabled, so that's OK.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/be7d963dcc80
Flags: in-testsuite+
https://hg.mozilla.org/mozilla-central/rev/be7d963dcc80

Updated

5 years ago
Target Milestone: --- → mozilla17
You need to log in before you can comment on or make changes to this bug.