Last Comment Bug 770418 - logging output is grody in identity/LogUtils.jsm
: logging output is grody in identity/LogUtils.jsm
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Identity (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Matthew N. [:MattN] (In Taipei until Sep. 23)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 23:15 PDT by Jed Parsons (use needinfo, please) [:jedp, :jparsons]
Modified: 2012-07-11 09:30 PDT (History)
3 users (show)
MattN+bmo: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v.1 Fix calls to log and cleanup usage (15.41 KB, patch)
2012-07-10 18:06 PDT, Matthew N. [:MattN] (In Taipei until Sep. 23)
jed+bmo: review+
MattN+bmo: review+
Details | Diff | Splinter Review

Description Jed Parsons (use needinfo, please) [:jedp, :jparsons] 2012-07-02 23:15:41 PDT
the prefix and optional args array (prefix, ...args) aren't playing well with each other.  it looks like args is coming out as a stringified array, not a list of strings.
Comment 1 Matthew N. [:MattN] (In Taipei until Sep. 23) 2012-07-10 18:06:38 PDT
Created attachment 640880 [details] [diff] [review]
v.1 Fix calls to log and cleanup usage

This was bothering me and made other problems harder to debug. If this is reviewed in time, I'll land this with the DOM code tonight.
Comment 2 Jed Parsons (use needinfo, please) [:jedp, :jparsons] 2012-07-10 22:37:37 PDT
Comment on attachment 640880 [details] [diff] [review]
v.1 Fix calls to log and cleanup usage

Review of attachment 640880 [details] [diff] [review]:
-----------------------------------------------------------------

That's beautiful.

Thanks both for fixing the log output and also for adding the stacktrace on error - that's going to be very helpful

r+
Comment 3 Matthew N. [:MattN] (In Taipei until Sep. 23) 2012-07-11 00:36:35 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c84e7d4fb37a

rs=dolske on IRC
Comment 4 Ed Morley [:emorley] 2012-07-11 09:30:54 PDT
https://hg.mozilla.org/mozilla-central/rev/c84e7d4fb37a

Note You need to log in before you can comment on or make changes to this bug.