Last Comment Bug 770421 - tidy/shorten CallObject::getCalleeFunction()
: tidy/shorten CallObject::getCalleeFunction()
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
-- normal (vote)
: mozilla16
Assigned To: Luke Wagner [:luke]
: Jason Orendorff [:jorendorff]
Depends on:
  Show dependency treegraph
Reported: 2012-07-02 23:28 PDT by Luke Wagner [:luke]
Modified: 2012-07-03 16:07 PDT (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

patch (21.12 KB, patch)
2012-07-02 23:28 PDT, Luke Wagner [:luke]
n.nethercote: review+
Details | Diff | Splinter Review

Description User image Luke Wagner [:luke] 2012-07-02 23:28:41 PDT
Created attachment 638599 [details] [diff] [review]

Simple syntactic patch:
 - rename 'getCalleeFunction' to 'callee' (so my expressions stop overflowing)
 - make 'callee' return a JSFunction&, since callee is always a non-null JSFunction
 - remove the maybe-NULL getCallee, change single caller to test isForEval.
 - remove unused setCallee
 - fix wrong comment
Comment 2 User image Ryan VanderMeulen [:RyanVM] 2012-07-03 16:07:14 PDT

Note You need to log in before you can comment on or make changes to this bug.