Last Comment Bug 770421 - tidy/shorten CallObject::getCalleeFunction()
: tidy/shorten CallObject::getCalleeFunction()
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Luke Wagner [:luke]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 23:28 PDT by Luke Wagner [:luke]
Modified: 2012-07-03 16:07 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (21.12 KB, patch)
2012-07-02 23:28 PDT, Luke Wagner [:luke]
n.nethercote: review+
Details | Diff | Review

Description Luke Wagner [:luke] 2012-07-02 23:28:41 PDT
Created attachment 638599 [details] [diff] [review]
patch

Simple syntactic patch:
 - rename 'getCalleeFunction' to 'callee' (so my expressions stop overflowing)
 - make 'callee' return a JSFunction&, since callee is always a non-null JSFunction
 - remove the maybe-NULL getCallee, change single caller to test isForEval.
 - remove unused setCallee
 - fix wrong comment
Comment 2 Ryan VanderMeulen [:RyanVM] 2012-07-03 16:07:14 PDT
https://hg.mozilla.org/mozilla-central/rev/767913118034

Note You need to log in before you can comment on or make changes to this bug.