Automated builds broken for SGS2

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: robert, Assigned: kanru)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I'm using the internal automated builds of Boot to Gecko to flash my Samsung Galaxy S2 (for testing, demos etc). After some digging in IRC with kanru and timdream, it tourns out that bug https://bugzilla.mozilla.org/show_bug.cgi?id=743612 is breaking the builds for SGS2.

Is this possible to fix, alternatively exclude, to fix the automated builds for SGS2?
(Assignee)

Updated

6 years ago
Blocks: 743612
Component: Graphics → General
Keywords: regression
Product: Core → Boot2Gecko
QA Contact: thebes → general
(Assignee)

Comment 1

6 years ago
Created attachment 638633 [details] [diff] [review]
Make sure we only initialize sGLContext/sFramebufferOpen once

But I'm not sure if the first call to GetLayerManager is on the correct nsWindow..
Attachment #638633 - Flags: review?(jones.chris.g)
Comment on attachment 638633 [details] [diff] [review]
Make sure we only initialize sGLContext/sFramebufferOpen once

Shouldn't cause any harm.
Attachment #638633 - Flags: review?(jones.chris.g) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/mozilla-inbound/rev/5c30c255b490
Assignee: nobody → kchen
Keywords: checkin-needed
(Reporter)

Comment 4

6 years ago
Wonderful! Seems to work now. Thank you!
https://hg.mozilla.org/mozilla-central/rev/5c30c255b490
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.