Remote mozbrowser crashes because of dlbi

RESOLVED WORKSFORME

Status

()

Core
DOM
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mounir, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 638705 [details]
Log

With the current m-c (e61399f31505), I'm getting a crash as soon as I'm using a remote browser.

I can reproduce that with those test pages:
http://oldworld.fr/mozilla/nss.html
http://oldworld.fr/mozilla/mozbrowser.html

With the following prefs:
dom.ipc.browser_frames.oop_by_default: true
dom.mozBrowserFramesEnabled: true
dom.mozBrowserFramesWhitelist: file:///,file://,http://oldworld.fr
dom.ipc.tabs.disabled: false
(Reporter)

Comment 1

6 years ago
This is random: I just got it working a few times.
(Reporter)

Comment 2

6 years ago
Created attachment 638709 [details]
Stack
Comment on attachment 638709 [details]
Stack

I've seen this error before, but not for a long time...
(Reporter)

Comment 4

6 years ago
Looking at the stack and the errors in the log, it looks more like something that doesn't handle properly e10s than a bug in the mozbrowser code.
Yeah, way back in bug 749018.

Updated

6 years ago
Crash Signature: [@ mozalloc_abort | NS_DebugBreak_P | mozilla::layout::RenderFrameParent::BuildLayer]
I think this is a recent regression.  Maybe display-list-based invalidation?
I can reproduce this and am bisecting.
(Reporter)

Comment 8

6 years ago
(In reply to Justin Lebar [:jlebar] from comment #6)
> I think this is a recent regression.  Maybe display-list-based invalidation?

I would bet on that too ;)
(Reporter)

Comment 9

6 years ago
Bug 539356 has been backed out and now things seem to be back to normal. This is unlikely a coincidence.
Depends on: 539356
(Reporter)

Updated

6 years ago
Summary: Remote mozbrowser crashes → Remote mozbrowser crashes because of dlbi
I can't reproduce this in the latest nightly, please re-open if you run into it again.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Updated

6 years ago
Blocks: 539356
No longer depends on: 539356
Keywords: regression
(Assignee)

Updated

5 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.