If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in mozilla::layers::ContainerLayerProperties::ComputeChangeInternal (64bit Windows/Linux)

RESOLVED WORKSFORME

Status

()

Core
Graphics: Layers
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({crash, regression})

16 Branch
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-cf7b6d51-0620-49b6-b04c-b3fac2120703 .
============================================================= 

Top frames:

0 	xul.dll 	mozilla::layers::ContainerLayerProperties::ComputeChangeInternal 	gfx/layers/LayerTreeInvalidation.cpp:174
1 	xul.dll 	mozilla::layers::LayerPropertiesBase::OldTransformedBounds 	gfx/layers/LayerTreeInvalidation.cpp:144
2 	xul.dll 	nsXMLHttpRequest::QueryInterface 	content/base/src/nsXMLHttpRequest.cpp:700
3 	xul.dll 	mozilla::layers::LayerPropertiesBase::ComputeChange 	gfx/layers/LayerTreeInvalidation.cpp:117
4 	xul.dll 	nsRegion::SetToElements 	gfx/src/nsRegion.cpp:295
5 	xul.dll 	mozilla::layers::ContainerLayerProperties::ComputeChangeInternal 	gfx/layers/LayerTreeInvalidation.cpp:190
6 	xul.dll 	nsXMLHttpRequest::QueryInterface 	content/base/src/nsXMLHttpRequest.cpp:700
7 	xul.dll 	nsRegion::SubRect 	gfx/src/nsRegion.cpp:1242
8 	xul.dll 	nsXMLHttpRequest::QueryInterface 	content/base/src/nsXMLHttpRequest.cpp:700
9 	xul.dll 	mozilla::layers::LayerPropertiesBase::ComputeChange 	gfx/layers/LayerTreeInvalidation.cpp:117
10 	xul.dll 	nsXMLHttpRequest::QueryInterface 	content/base/src/nsXMLHttpRequest.cpp:700


This started happening on 2012-07-01 with Windows and Linux 64bit Nightly 16.0a1 builds.
See https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3AContainerLayerProperties%3A%3AComputeChangeInternal%28void%20%28*%29%28mozilla%3A%3Alayers%3A%3AContainerLayer*%2C%20nsIntRegion%20const%26%29%29 and https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3AContainerLayerProperties%3A%3AComputeChangeInternal for more crashes with those signatures.
Looks like it could be a dlbi regression.
Blocks: 539356

Updated

5 years ago
Component: Graphics → Graphics: Layers
Keywords: regression
OS: Windows NT → All
QA Contact: thebes → graphics-layers
Version: Trunk → 16 Branch
There are no comments on the crash reports, so pretty much all we have to go on here are the stacks. Not much I can do here, Matt, unless you can think of something from that.
I think this is caused by us not holding strong refs to the Layers in the LayerTreeInvalidation structure and then comparing raw pointers.

Holding a strong ref should prevent this from happening.

Comment 4

5 years ago
There are no crashes over the last four weeks.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.