Last Comment Bug 770629 - Divs aren't rendered when using CSS 3D transforms
: Divs aren't rendered when using CSS 3D transforms
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 16 Branch
: x86 All
: -- normal (vote)
: mozilla17
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks: dlbi
  Show dependency treegraph
 
Reported: 2012-07-03 12:24 PDT by Bobby Richter [:secretrobotron]
Modified: 2012-07-19 07:35 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
further reduced testcase (908 bytes, text/html)
2012-07-17 15:13 PDT, Jonathan Watt [:jwatt]
no flags Details
patch containing regression test (2.30 KB, patch)
2012-07-17 20:53 PDT, Jonathan Watt [:jwatt]
matt.woodrow: review+
Details | Diff | Review

Description Bobby Richter [:secretrobotron] 2012-07-03 12:24:16 PDT
http://robothaus.org:8888/cornfield/view/4fe23b63a4886fd25f000004.html

The link above should show a video with a spinning cube on the bottom right. In Firefox 16.0a1 (2012-07-03), the planes of the cube and its shadow appear intermittently, but it displays properly in Chrome and Firefox 13.
Comment 1 Bobby Richter [:secretrobotron] 2012-07-03 12:24:46 PDT
I will try to shave down the example a bit for easier inspection.
Comment 2 Bobby Richter [:secretrobotron] 2012-07-03 12:55:04 PDT
More isolated example: http://robothaus.org/mozilla/bugs/770629.html

Notice that as the cube moves into the center of the page, it starts to lose more planes. At 0,0 the cube seems fine.
Comment 3 Alice0775 White 2012-07-03 13:58:14 PDT
Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/0d9f7fb55226
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120629192951
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/cd6d52bdf2d8
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 ID:20120629200651
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0d9f7fb55226&tochange=cd6d52bdf2d8

Suspected: Bug 539356
Comment 4 Jonathan Watt [:jwatt] 2012-07-17 15:13:34 PDT
Created attachment 643158 [details]
further reduced testcase
Comment 5 Jonathan Watt [:jwatt] 2012-07-17 20:53:21 PDT
Created attachment 643251 [details] [diff] [review]
patch containing regression test
Comment 6 Jonathan Watt [:jwatt] 2012-07-17 20:54:38 PDT
Not quite sure whether I should assign this to myself and call it done with the regression test, and then let you fix it in your DLBI queue...or something else.
Comment 7 Matt Woodrow (:mattwoodrow) 2012-07-18 07:04:45 PDT
Comment on attachment 643251 [details] [diff] [review]
patch containing regression test

Review of attachment 643251 [details] [diff] [review]:
-----------------------------------------------------------------

This should probably be in the transform3d folder since it's using rotateY and perspective.

And yes, I think we should close these bugs once the test lands. Probably best to assign them to yourself asap too, so that other people don't accidentally duplicate your work.
Comment 9 Ed Morley [:emorley] 2012-07-19 07:35:08 PDT
https://hg.mozilla.org/mozilla-central/rev/d494d578acb5

Note You need to log in before you can comment on or make changes to this bug.