sh.exe crashed at building dom/tests/mochitest/dom-level2-html with pymake

RESOLVED DUPLICATE of bug 770558

Status

--
critical
RESOLVED DUPLICATE of bug 770558
6 years ago
8 months ago

People

(Reporter: masayuki, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression

Firefox Tracking Flags

(Not tracked)

Details

I cannot reproduce this bug with a tree pulled last week or with GNU make.

nsIWorkerTest.idl
worker/
worker/chrome.manifest
worker/components/
worker/components/interfaces.manifest
worker/components/WorkerTest.js
worker/components/WorkerTest.manifest
worker/components/WorkerTest.xpt
worker/install.rdf
worker/worker.js
      0 [main] sh 9960 handle_exceptions: Exception: STATUS_ACCESS_VIOLATION
    656 [main] sh 9960 open_stackdumpfile: Dumping stack trace to sh.exe.stackdump
... (a lot of files are listed) failed, return code 101120
c:\Users\...\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C files libs' failed, return code 2
c:\Users\...\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C dom-level2-html libs' failed, return code 2
c:\Users\...\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C mochitest libs' failed, return code 2
c:\Users\...\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C tests libs' failed, return code 2
c:\Users\...\config\makefiles\target_libs.mk:18:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C dom libs' failed,
return code 2
c:\Users\...\config\rules.mk:607:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py libs_tier_platform' failed, return code 2
c:\Users\...\config\rules.mk:572:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py  tier_platform' failed, return code
2
c:\Users\...\client.mk:349:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -sj4 -C c:/Users/.../../firefox-debug-build' failed, return code 2
c:\Users\...\client.mk:149:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -f c:/Users/.../client.mk realbuild' failed, return code 2

my mozconfig is:

mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/../firefox-debug-build

mk_add_options MOZ_MAKE_FLAGS="-sj4"

ac_add_options --enable-tests
ac_add_options --enable-logging
ac_add_options --disable-optimize
ac_add_options --enable-debug

ac_add_options --disable-installer

The sh.exe.stackdump:

MSYS-1.0.11 Build:2009-05-23 19:33
Exception: STATUS_ACCESS_VIOLATION at eip=60128864
eax=2F737265 ebx=0A011B80 ecx=6019D3BC edx=2F737267 esi=00271DF8 edi=0028B3A8
ebp=00269D58 esp=00269D40 program=C:\mozilla-build\msys\bin\sh.exe
cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
Stack trace:
Frame     Function  Args
00269D58  60128864  (2F737265, 0028B3A8, 0028B3A8, 00000000)
00269D00  601285E3  (00000000, 00000000, 00000000, 00000000)
End of stack trace
Oops, not dom/wokers.

I misread the console log.

worker/worker.js
      0 [main] sh 9960 handle_exceptions: Exception: STATUS_ACCESS_VIOLATION
    656 [main] sh 9960 open_stackdumpfile: Dumping stack trace to sh.exe.stackdump
c:\Users\...\firefox-debug-build\dom\tests\mochitest\dom-level2-html\files\Makefile:227:0: command ' (a lot of files) ' failed, return code 101120
c:\Users\...\config\makefiles\target_libs.mk:103:0: command 'c:/mozilla-build/python/python.exe c:/Users/.../build/pymake/pymake/../make.py -C files libs' failed, return code 2

So, building dom/tests/mocitest/dom-level2-html, sh.exe crashed.
Summary: sh.exe crashed at building dom/workers with pymake → sh.exe crashed at building dom/tests/mochitest/dom-level2-html with pymake
Bug 770558?
(In reply to Masatoshi Kimura [:emk] from comment #2)
> Bug 770558?

Oh, that's it! Thanks.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 770558

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.