Disable functionality for clearing prefetch

VERIFIED FIXED in Firefox 15

Status

()

Core
Widget: Win32
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: bbondy, Assigned: bbondy)

Tracking

Trunk
mozilla16
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 unaffected, firefox15+ verified, firefox16 verified)

Details

(Whiteboard: [qa!])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
The STARTUP_USING_PRELOAD_TRIAL histogram in correlation to startup time analysis in Bug 765850 has shown us that other than the slowest 1% of startups, prefetch disabling hurts us.

We need to land a patch that disables the functionality of clearing prefetch, but keeps everything else in place.  

This task will ensure that clearing does not happens on beta (will be v15) and Release (will be v14) on the next migration.

We will request that this goes on Aurora (currently v15) after it lands on Nightly (currently v16).
Hmm okay (makes sense after reading the analysis). For windows users that dogfood Aurora and Nightly, what should we do about the fact that they now have prefetch files that are 0 KB and read only? Are they permanently stuck with those prefetch files unless they explicitly go into C:\Windows\Prefetch and remove them? Or is there something we can do on our end?

Is this a permanent backout of this functionality or a pref off until a better approach is found?
(Assignee)

Comment 2

5 years ago
I'll be posting a follow up email about how this will be reverted completely for all users including those of Aurora and Nightly a bit later today.  In short after the next migration I'll land a new patch on the new Nightly and Aurora that deletes prefetch files only if they are read only and 0 sized. Then that task itself will be reverted before the migration after that.   In the end, unfortunately this is probably a permanent backout.

Updated

5 years ago
tracking-firefox15: --- → ?
(Assignee)

Comment 3

5 years ago
Created attachment 639100 [details] [diff] [review]
Patch v1

The reason I'm just #if 0'ing it out is because there will be another patch in a bug I'm about to post that will re-add this functionality.  That new patch will not land until after the next migration.  It will re-add the functionality but change prefetch clearing so it deletes the prefetch only when it is 0 bytes and read-only.
Attachment #639100 - Flags: review?(taras.mozilla)
(Assignee)

Updated

5 years ago
Blocks: 770899
(Assignee)

Updated

5 years ago
Blocks: 770911

Comment 4

5 years ago
Comment on attachment 639100 [details] [diff] [review]
Patch v1

rubberstamp
Attachment #639100 - Flags: review?(taras.mozilla) → review+
(Assignee)

Comment 5

5 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/dfca0a052c47

Tested this patch on elm, also tested to make sure upgrades are fine and are unaffected since this touches the maintenance service.
status-firefox14: --- → unaffected
status-firefox15: --- → affected
status-firefox16: --- → affected
Target Milestone: --- → mozilla16
(Assignee)

Comment 6

5 years ago
Comment on attachment 639100 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 692255
User impact if declined: We don't want to clear people's prefetch on the Beta channel since we found that clearing is a net negative.
Testing completed (on m-c, etc.): Tested on elm already, pushed to m-i so should be on m-c soon too.
Risk to taking this patch (and alternatives if risky): Low
String or UUID changes made by this patch: None
Attachment #639100 - Flags: approval-mozilla-aurora?

Updated

5 years ago
QA Contact: jsmith
Whiteboard: [qa+]

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/dfca0a052c47
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox16: affected → fixed

Comment 8

5 years ago
Comment on attachment 639100 [details] [diff] [review]
Patch v1

[Triage Comment]
Low risk, prevents a new regression in FF15.
Attachment #639100 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified on Nightly.
Status: RESOLVED → VERIFIED
tracking-firefox15: ? → +

Updated

5 years ago
Whiteboard: [qa+] → [qa!]
(Assignee)

Comment 10

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/3ca4c24f0c34
status-firefox15: affected → fixed

Updated

5 years ago
status-firefox16: fixed → verified
Whiteboard: [qa!] → [qa+]

Updated

5 years ago
status-firefox15: fixed → verified

Updated

5 years ago
Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.