Remove Account prompt should say which account

RESOLVED FIXED in mozilla1.2alpha

Status

SeaMonkey
MailNews: Account Configuration
P2
minor
RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Jesse Ruderman, Assigned: Christopher Aillon (sabbatical, not receiving bugmail))

Tracking

({polish})

Trunk
mozilla1.2alpha
polish
Bug Flags:
blocking1.4b -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

2.38 KB, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
(not reading, please use seth@sspitzer.org instead)
: approval1.4b+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
mail, edit->account settings, remove account

'Are you sure you want to remove this account?'
should be
'Are you sure you want to remove the account "davidr8@home.com"?'

Updated

17 years ago
QA Contact: esther → nbaca

Comment 1

17 years ago
Taking.
Assignee: racham → jg
OS: Windows 98 → All
Hardware: PC → All
Target Milestone: --- → mozilla0.9.8

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: polish
Priority: -- → P2

Comment 2

16 years ago
Bouncing out, hope someone with more time than I catches.
Assignee: jg → racham
Status: ASSIGNED → NEW

Updated

16 years ago
Keywords: mozilla1.0.1, nsbeta1

Comment 3

16 years ago
Discussed in mail news bug meeting.  Decided to minus this bug.
Keywords: nsbeta1 → nsbeta1-
Target Milestone: mozilla0.9.8 → mozilla1.2alpha

Updated

16 years ago
Keywords: mozilla1.1

Comment 4

16 years ago
*** Bug 137497 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Flags: blocking1.4b?

Updated

15 years ago
Flags: blocking1.4b? → blocking1.4b-
May as well take this.
Assignee: racham → evang-obsolete
Er, use the right address this time.  ;-)
Assignee: evang-obsolete → caillon
Comment on attachment 122432 [details] [diff] [review]
Patch

r=me if you get sr=sspitzer
Attachment #122432 - Flags: review+
Comment on attachment 122432 [details] [diff] [review]
Patch

don't go right through prefs.

do account.server.prettyName

see nsMsgFolderDataSource::createFolderNameNode()
and
nsMsgFolder::GetName()

for why I think that's right.

for bonus points, rewrite to remove window.confirm.

you should be getting an assert about not using window.confirm from chrome.
Attachment #122432 - Flags: superreview-
var promptService =
Components.classes["@mozilla.org/embedcomp/prompt-service;1"].getService(Components.interfaces.nsIPromptService);

if (!promptService.confirm(window, title, message))
...
Created attachment 122516 [details] [diff] [review]
Patch v2

Addresses seth's comments.  I can't believe I missed the prettyName on
nsIMsgIcomingServer since I found key which is right above that.  Weird...
Attachment #122432 - Attachment is obsolete: true
Comment on attachment 122516 [details] [diff] [review]
Patch v2

r/sr/a=sspitzer

thanks chris!
Attachment #122516 - Flags: superreview+
Attachment #122516 - Flags: review+
Attachment #122516 - Flags: approval1.4b+
Checking in mailnews/base/prefs/resources/content/AccountManager.js;
/cvsroot/mozilla/mailnews/base/prefs/resources/content/AccountManager.js,v  <--
 AccountManager.js
new revision: 1.96; previous revision: 1.95
done
Checking in mailnews/base/prefs/resources/locale/en-US/prefs.properties;
/cvsroot/mozilla/mailnews/base/prefs/resources/locale/en-US/prefs.properties,v 
<--  prefs.properties
new revision: 1.27; previous revision: 1.26
done
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.