Last Comment Bug 771087 - 2 strict warnings in test_constants.xul
: 2 strict warnings in test_constants.xul
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: js-ctypes (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: David Teller [:Yoric] (please use "needinfo")
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks: 763848
  Show dependency treegraph
 
Reported: 2012-07-05 03:56 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-07-06 07:49 PDT (History)
2 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix warnings (1.29 KB, patch)
2012-07-05 03:59 PDT, David Teller [:Yoric] (please use "needinfo")
dteller: review+
bugzillamozillaorg_serge_20140323: feedback+
Details | Diff | Splinter Review
Fix warnings (1.83 KB, patch)
2012-07-05 04:26 PDT, David Teller [:Yoric] (please use "needinfo")
dteller: review+
Details | Diff | Splinter Review

Description Serge Gautherie (:sgautherie) 2012-07-05 03:56:00 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1341473203.1341476269.12844.gz&fulltext=1
WINNT 5.2 comm-central-trunk debug test mochitest-other on 2012/07/05 00:26:43
{
JavaScript strict warning: chrome://mochitests/content/chrome/dom/system/tests/test_constants.xul, line 62: anonymous function does not always return a value
JavaScript strict warning: chrome://mochitests/content/chrome/dom/system/tests/test_constants.xul, line 65: anonymous function does not always return a value
}
Comment 1 David Teller [:Yoric] (please use "needinfo") 2012-07-05 03:59:34 PDT
Created attachment 639278 [details] [diff] [review]
Fix warnings
Comment 2 David Teller [:Yoric] (please use "needinfo") 2012-07-05 03:59:53 PDT
Thanks, fixing this.
Comment 3 Serge Gautherie (:sgautherie) 2012-07-05 04:22:28 PDT
Comment on attachment 639278 [details] [diff] [review]
Fix warnings

Review of attachment 639278 [details] [diff] [review]:
-----------------------------------------------------------------

At first glance, this looks like what I expected.

Did you actually mean to self-review this?

::: dom/system/tests/test_constants.xul
@@ +48,2 @@
>    ok(true, "test_constants.xul: Chrome worker created");
>    worker.onerror = function(error) {

Nit: While here, could you give names to anonymous functions?

@@ +48,4 @@
>    ok(true, "test_constants.xul: Chrome worker created");
>    worker.onerror = function(error) {
>      error.preventDefault();
>      ok(false, "error "+error);

Nit: While here, could you add missing spaces around '+'s?
Comment 4 David Teller [:Yoric] (please use "needinfo") 2012-07-05 04:26:36 PDT
Created attachment 639286 [details] [diff] [review]
Fix warnings

Done. Thanks for the review and for spotting the warnings!
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-05 18:29:40 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/bf5a2135b072

Note You need to log in before you can comment on or make changes to this bug.