scrollLeft, scrollWidth doesn't work on Firefox 13.0.1/Linux AMD64

RESOLVED DUPLICATE of bug 293186

Status

()

RESOLVED DUPLICATE of bug 293186
6 years ago
6 years ago

People

(Reporter: vadim, Unassigned)

Tracking

13 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120615233552

Steps to reproduce:

This is how to reproduce:
<!DOCTYPE html>
<html>
    <head>
        <title></title>
        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
        <script type="text/javascript">
            function test(obj){
                console.log('Scroll left = ' + obj.scrollLeft);
            }
        </script>
    </head>
    <body>
        <div>TODO write content</div>
        <form>
            <input type="text" id="id" onkeydown="test(this)" />
        </form>
    </body>
</html>



Actual results:

I've got:
 Scroll left = 0


Expected results:

Should be: 
  Scroll left = Number

Comment 1

6 years ago
This is same as Bug 476829.
And it is duplication of bug 293186

Updated

6 years ago
Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 293186
You need to log in before you can comment on or make changes to this bug.