Last Comment Bug 771248 - Enable WebRTC in builds by default (except for Android/B2G)
: Enable WebRTC in builds by default (except for Android/B2G)
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: WebRTC (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: [:jesup] on pto until 2016/7/5 Randell Jesup
:
Mentors:
Depends on: 771588
Blocks: 691234 771981
  Show dependency treegraph
 
Reported: 2012-07-05 11:36 PDT by [:jesup] on pto until 2016/7/5 Randell Jesup
Modified: 2012-07-27 10:23 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Flip webrtc to be built by default (except Android/B2G) (1.06 KB, patch)
2012-07-05 11:36 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review
Flip webrtc build pref to on (1.05 KB, patch)
2012-07-05 13:50 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review
Flip webrtc build pref to on (1.85 KB, patch)
2012-07-05 23:13 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
roc: review+
Details | Diff | Review
Flip webrtc build pref to on and disable PGO for libvpx offset generation (2.60 KB, patch)
2012-07-06 15:07 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review
Flip webrtc build pref to on (1.86 KB, patch)
2012-07-06 20:03 PDT, [:jesup] on pto until 2016/7/5 Randell Jesup
no flags Details | Diff | Review

Description [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 11:36:45 PDT
Created attachment 639414 [details] [diff] [review]
Flip webrtc to be built by default (except Android/B2G)

This is in preparation for landing getUserMedia (bug 691234); I want to shake out any build issues (especially on the wide selection of developer's systems; it works on Try) before landing navigator.mozGetUserMedia().
Comment 1 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 13:50:11 PDT
Created attachment 639457 [details] [diff] [review]
Flip webrtc build pref to on
Comment 2 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 19:18:29 PDT
Try without code to disable for ANdroid & B2G:
https://tbpl.mozilla.org/?tree=Try&rev=36739e0635df
(Note: talos reds, build purple are due to hg/etc infrastructure failure during the run.)

Try of patch with webrtc disabled for Android/B2G:
https://tbpl.mozilla.org/?tree=Try&rev=0c8116c581a9
Comment 3 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 19:24:25 PDT
Comment on attachment 639457 [details] [diff] [review]
Flip webrtc build pref to on

Time to flip the pref for webrtc in preparation for landing getUserMedia (up for review now).  Warning was given to people in the Platform weekly meeting and notes.
Comment 4 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-07-05 19:32:43 PDT
Comment on attachment 639457 [details] [diff] [review]
Flip webrtc build pref to on

Review of attachment 639457 [details] [diff] [review]:
-----------------------------------------------------------------

Don't you need to switch the configure option to --disable-webrtc?
Comment 5 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 23:13:51 PDT
Created attachment 639589 [details] [diff] [review]
Flip webrtc build pref to on
Comment 6 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-05 23:16:27 PDT
Comment on attachment 639589 [details] [diff] [review]
Flip webrtc build pref to on

Flip pref name to match new default (--disable-webrtc works in either case, and it defaults to on either way, but this gives the correct impression of the default if you do configure --help)
Comment 7 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 08:35:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2538f744029c
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-07-06 10:05:48 PDT
Backed out for failing PGO builds the exact same way it did when you pushed it to try.

http://hg.mozilla.org/integration/mozilla-inbound/rev/fec28c1afb63
Comment 9 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 11:02:56 PDT
This bounce was because of bug 771588, which we had no reason to believe would show up without PGO being turned on for libvpx.  (We ran across the bug with PGO on when trying to merge gkmedia back into libxul when doing tests for bug 768325, and the bug went away with PGO off, so we didn't think there was any reason to anticipate a problem with the landing.)

My trys last night were ok (modulo infrastructure failure), but being normal trys didn't run PGO builds.
Comment 10 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 15:07:06 PDT
Created attachment 639824 [details] [diff] [review]
Flip webrtc build pref to on and disable PGO for libvpx offset generation
Comment 11 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 15:08:00 PDT
Try (still) running at https://tbpl.mozilla.org/?tree=Try&pusher=rjesup@wgate.com
Comment 12 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 15:09:37 PDT
Comment on attachment 639824 [details] [diff] [review]
Flip webrtc build pref to on and disable PGO for libvpx offset generation

asking any build peer for review... (on the assumption the try goes ok - it's running with PGO)
Comment 13 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 20:03:07 PDT
Created attachment 639913 [details] [diff] [review]
Flip webrtc build pref to on
Comment 14 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-06 20:05:53 PDT
libvpx changes are now in patch on bug 771588
Comment 15 [:jesup] on pto until 2016/7/5 Randell Jesup 2012-07-08 05:53:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/f86b9868abd9
Comment 16 Ryan VanderMeulen [:RyanVM] 2012-07-08 10:50:43 PDT
https://hg.mozilla.org/mozilla-central/rev/f86b9868abd9

Note You need to log in before you can comment on or make changes to this bug.