Last Comment Bug 771317 - Fix comment about FASTCALL and inline functions
: Fix comment about FASTCALL and inline functions
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Nathan Froyd [:froydnj]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 13:37 PDT by Jeff Muizelaar [:jrmuizel]
Modified: 2012-08-09 07:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix comment about FASTCALL and inline functions (811 bytes, patch)
2012-07-05 13:37 PDT, Jeff Muizelaar [:jrmuizel]
respindola: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-07-05 13:37:51 PDT
Created attachment 639452 [details] [diff] [review]
Fix comment about FASTCALL and inline functions

Calling convention does not make a difference on functions that are inlined, but that feels obvious because no call is being made. Inline functions are not necessarily inlined so this comment is somewhat misleading.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-07-05 14:31:25 PDT
Comment on attachment 639452 [details] [diff] [review]
Fix comment about FASTCALL and inline functions

Review of attachment 639452 [details] [diff] [review]:
-----------------------------------------------------------------

I just tested and both clang and gcc apply to regparm attribute to an inline function that is not inlined.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-08-09 07:29:08 PDT
This was fixed in git's e8160e9af955ef8b65e5499b9b209490b3818ed8.

Note You need to log in before you can comment on or make changes to this bug.