Closed Bug 771407 Opened 9 years ago Closed 9 years ago

crash in mozilla::FrameLayerBuilder::ProcessRemovedDisplayItems

Categories

(Core :: Layout, defect)

18 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox17 --- unaffected
firefox18 - verified

People

(Reporter: jsmith, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression, Whiteboard: [Desktop WebRT])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-bb571f8c-8a7f-4299-8bd3-d002a2120705 .
============================================================= 

Found today while looking at crash stats. Looks like its a regression from bug 539356. 

Failing changeset: http://hg.mozilla.org/mozilla-central/rev/f568fc280fb0

This appears to be causing some crashes in the desktop web runtime:

https://crash-stats.mozilla.com/report/list?product=WebappRuntime&version=WebappRuntime%3A16.0a1&query_search=signature&query_type=contains&reason_type=contains&date=07%2F06%2F2012%2002%3A28%3A12&range_value=4&range_unit=weeks&hang_type=any&process_type=any&do_query=1&signature=mozilla%3A%3AFrameLayerBuilder%3A%3AProcessRemovedDisplayItems%28mozilla%3A%3AFrameLayerBuilder%3A%3ADisplayItemDataEntry*%2C%20void*%29

Don't know any reproduction steps to reproduce this though.
Blocks: dlbi
Whiteboard: [Desktop WebRT]
There's not enough information here for us to determine whether the relanded DLBI still has this problem.  Please reopen if this reappears.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
(In reply to Chris Jones [:cjones] [:warhammer] from comment #1)
> There's not enough information here for us to determine whether the relanded
> DLBI still has this problem.  Please reopen if this reappears.
It has indeed reappeared.

Signature 	mozilla::FrameLayerBuilder::ProcessRemovedDisplayItems(mozilla::FrameLayerBuilder::DisplayItemDataEntry*, void*) More Reports Search
UUID	ed9900d7-7652-4720-997e-12a6b2120930
Date Processed	2012-09-30 19:49:56
Uptime	320
Last Crash	5.6 minutes before submission
Install Age	5.2 hours since version was first installed.
Install Time	2012-09-30 14:34:49
Product	Firefox
Version	18.0a1
Build ID	20120930030610
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x18
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x95c4, AdapterSubsysID: 210f17aa, AdapterDriverVersion: 8.970.100.3000
Has dual GPUs. GPU #2: AdapterVendorID2: 0x8086, AdapterDeviceID2: 0x2a42, AdapterSubsysID2: 211317aa, AdapterDriverVersion2: 8.792.5.2000D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x95c4
Total Virtual Memory	4294836224
Available Virtual Memory	3399856128
System Memory Use Percentage	61
Available Page File	4921458688
Available Physical Memory	1595879424

Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::FrameLayerBuilder::ProcessRemovedDisplayItems 	layout/base/FrameLayerBuilder.cpp:954
1 	xul.dll 	nsTHashtable<mozilla::FrameLayerBuilder::DisplayItemDataEntry>::s_EnumStub 	obj-firefox/dist/include/nsTHashtable.h:487
2 	xul.dll 	PL_DHashTableEnumerate 	obj-firefox/xpcom/build/pldhash.cpp:716
3 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::Finish 	layout/base/FrameLayerBuilder.cpp:2578
4 	xul.dll 	mozilla::FrameLayerBuilder::BuildContainerLayerFor 	layout/base/FrameLayerBuilder.cpp:2875
5 	xul.dll 	nsDisplayOwnLayer::BuildLayer 	layout/base/nsDisplayList.cpp:2672
6 	xul.dll 	mozilla::FramePropertyTable::Get 	layout/base/FramePropertyTable.cpp:74
7 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ProcessDisplayItems 	layout/base/FrameLayerBuilder.cpp:2125

More reports at:
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3AFrameLayerBuilder%3A%3AProcessRemovedDisplayItems%28mozilla%3A%3AFrameLayerBuilder%3A%3ADisplayItemDataEntry*%2C+void*%29
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Version: unspecified → 18 Branch
It's #5 top browser crasher in today's build.
Keywords: topcrash
Assignee: nobody → matt.woodrow
Does this still show up in the 10/4 nightly?
(In reply to Chris Jones [:cjones] [:warhammer] from comment #4)
> Does this still show up in the 10/4 nightly?
It stopped spiking after 18.0a1/20121002. The working range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=85dd8e346102&tochange=635fcc11d2b1
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795899
The spike went away, but not all crashes. It's #19 top browser crasher in today's build.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Is this still showing up? It's hopefully fixed by bug 795674.
(In reply to Matt Woodrow (:mattwoodrow) from comment #10)
> Is this still showing up? It's hopefully fixed by bug 795674.
There are crashes up to 19.0a1/20121011 and 18.0a2/20121014.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Depends on: 795674
Target Milestone: --- → mozilla19
Bug 795674 was uplifted to Aurora.
While checking on Socorro, there aren't any new crashes reported containing this signature.
Status: RESOLVED → VERIFIED
QA Contact: manuela.muntean
You need to log in before you can comment on or make changes to this bug.