-moz-box-sizing: border-box (image with padding, height and no width has strange margin)

RESOLVED DUPLICATE of bug 801116

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 801116
5 years ago
4 years ago

People

(Reporter: Sasha Paunovic, Unassigned)

Tracking

({regression, testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.76 KB, text/html
Details
(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.47 Safari/536.11

Steps to reproduce:

-moz-box-sizing: border-box
Set padding and height(only) on an image
Very short example  http://jsfiddle.net/jRVfU/



Actual results:

Padding adds margin


Expected results:

Not that

Comment 1

5 years ago
There are 2 regression window

#1
Good: 07-Dec-2006 0533
Bad(float left broken): 08-Dec-2006 0543
Bonsai Log:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-12-07+02%3A00%3A00&maxdate=2006-12-08+06%3A00%3A00&cvsroot=%2Fcvsroot

#2
Bad(float left broken): 12-Jun-2007 0757
Bad(float left works again, but padding broken):12-Jun-2007 1424
Bonsai Log:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2007-06-12+04%3A00%3A00&maxdate=2007-06-12+15%3A00%3A00&cvsroot=%2Fcvsroot

Updated

5 years ago
Status: UNCONFIRMED → NEW
Component: DOM: CSS Object Model → Layout
Ever confirmed: true
Keywords: regression
Blocks: 243412

Updated

5 years ago
Keywords: testcase
OS: Windows 7 → All
Hardware: x86 → All
Summary: -moz-box-sizing: border-box → -moz-box-sizing: border-box (image with padding, height and no width has strange margin)

Comment 2

5 years ago
Created attachment 641733 [details]
testcase

Comment 3

4 years ago
Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0

seems to work now, anyone here to confirm?
I can confirm it works correctly now.

So this leaves us with one bug left to be able to unprefix box-sizing...
https://bugzilla.mozilla.org/show_bug.cgi?id=520992
Fixed in range https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=942ed5747b63&tochange=8f145599e4bf
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801116
You need to log in before you can comment on or make changes to this bug.