Last Comment Bug 771492 - Enable the dom.experimental forms by default in fennec
: Enable the dom.experimental forms by default in fennec
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: mozilla16
Assigned To: Raphael Catolino (:raphc)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 344616 446510
  Show dependency treegraph
 
Reported: 2012-07-06 06:04 PDT by Raphael Catolino (:raphc)
Modified: 2012-12-28 11:56 PST (History)
4 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (948 bytes, patch)
2012-07-06 15:26 PDT, Raphael Catolino (:raphc)
mark.finkle: review+
Details | Diff | Splinter Review

Description Raphael Catolino (:raphc) 2012-07-06 06:04:21 PDT
Since we've got the ui for the <input> element on fennec, we should enable the experimental forms.
Comment 1 Mounir Lamouri (:mounir) 2012-07-06 06:10:27 PDT
So, Mark, with this pref enabled on Fennec, the browser will support <input type='number'> and later other input types (as they come). Actually, Fennec already has a UI for <input type='number'> (it is showing a number-only keyboard) so enabling this pref will only make all special features like form validation, stepDown(), stepUp() and .valueAsNumber to work in JS.

Raphael, could you write a patch (just change mobile/android/app/mobile.js) and ask a review to :mfinkle?
Comment 2 Raphael Catolino (:raphc) 2012-07-06 15:26:34 PDT
Created attachment 639828 [details] [diff] [review]
patch
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-06 20:03:13 PDT
Comment on attachment 639828 [details] [diff] [review]
patch

I'm looking forward to the cool new form features
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-09 18:04:30 PDT
https://hg.mozilla.org/mozilla-central/rev/baa345c66f85

Note You need to log in before you can comment on or make changes to this bug.