The default bug view has changed. See this FAQ.

FileHandle: getFile() should return a DOMRequest (instead of a FileRequest)

RESOLVED FIXED in Firefox 15

Status

()

Core
DOM
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: janv, Assigned: janv)

Tracking

unspecified
mozilla16
Points:
---

Firefox Tracking Flags

(firefox13 unaffected, firefox14 unaffected, firefox15 fixed, firefox16 fixed, firefox-esr10 unaffected)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

5 years ago
Created attachment 639938 [details] [diff] [review]
fix
Assignee: nobody → Jan.Varga
Status: NEW → ASSIGNED
Attachment #639938 - Flags: review?(jonas)
Comment on attachment 639938 [details] [diff] [review]
fix

Review of attachment 639938 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great!
Attachment #639938 - Flags: review?(jonas) → review+
Comment on attachment 639938 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
This is a bug in a new feature

User impact if declined:
There's a risk that developers will misunderstand how this new API is supposed to be used. This has already happened which is how we found this bug. Such misunderstanding will lead to a slower website and probably in the future we'll be foreced to break this behavior, causing websites to break.

Testing completed (on m-c, etc.):
Patch contains mochitest and should land very soon on m-c.

Risk to taking this patch (and alternatives if risky): 
There's very little risk. The patch logic is very simple, and it strictly speaking just removes functionality from websites.

String or UUID changes made by this patch:
Only changes the UUID of APIs which are new for FF15
Attachment #639938 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5549659290f7
https://hg.mozilla.org/mozilla-central/rev/5549659290f7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla16

Comment 6

5 years ago
Comment on attachment 639938 [details] [diff] [review]
fix

[Triage Comment]
New APIs in FF15, so no problem with approving this change. Can you make sure to block the original feature bug on this one? Thanks.
Attachment #639938 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 726593
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/de20a11fba94
status-firefox-esr10: --- → unaffected
status-firefox13: --- → unaffected
status-firefox14: --- → unaffected
status-firefox15: --- → fixed
status-firefox16: --- → fixed

Updated

5 years ago
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.