Closed Bug 771554 Opened 7 years ago Closed 7 years ago

TPS should use modern mozbase packages from the tree

Categories

(Testing Graveyard :: TPS, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla19

People

(Reporter: k0scist, Assigned: samdgarrett)

References

Details

(Whiteboard: [mozbase])

Attachments

(2 files, 1 obsolete file)

http://mxr.mozilla.org/mozilla-central/source/testing/tps/setup.py

TPS is pegged to some old versions of mozbase packages and seems to
get them from http://people.mozilla.org/~jgriffin/packages/ . TPS
should be upgraded to use modern mozbase dependencies that are
mirrored to mozilla-central:

http://mxr.mozilla.org/mozilla-central/source/testing/mozbase

TPS is also installed in its own virtualenv via
http://mxr.mozilla.org/mozilla-central/source/testing/tps/INSTALL.sh
. ABICT this is not net-safe.  Instead, it should use the in-tree
virtualenv and install in the standard way:

http://mxr.mozilla.org/mozilla-central/source/build/virtualenv/Makefile.in

Note that the package upgrades should be done before the virtualenv
installation or we will have incompatible versions in-tree
Whiteboard: [mozbase]
Blocks: 775756
Attached patch Pointed dependencies to mozbase. (obsolete) — Splinter Review
This is the first patch for this bug, just updating the dependencies. I ran this once installed with the newer versions:

runtps --testfile=/Users/sgarrett/Documents/Mozilla_Source/src/services/sync/tests/tps/test_sync.js --binary=http://stage.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/services-central-macosx64/1340656938/firefox-16.0a1.en-US.mac.dmg

to see if anything would break and nothing broke on my box so I don't see any issues with compatibility in these newer versions.
Attachment #646787 - Flags: review?(jgriffin)
Comment on attachment 646787 [details] [diff] [review]
Pointed dependencies to mozbase.

Let's update the deps list so that they indicate the current version of the mozbase components in m-c.  The reason is, we don't know that TPS is compatible with every version of mozrunner between 3.0a and 5.8, for example, so it's safest just to peg the dependency at 5.8.

We can also just remove the dependency_links field in setup(); it will get the packages from pypi by default, or (eventually) have them pick those packages up from the m-c objdir.
Attachment #646787 - Flags: review?(jgriffin) → review-
Attachment #646787 - Attachment is obsolete: true
Attachment #649482 - Flags: review?(jgriffin)
Comment on attachment 649482 [details] [diff] [review]
Updated dependencies and removed unused pulse code.

Looks good, thanks!

https://hg.mozilla.org/mozilla-central/rev/602c2e7ee0d2
Attachment #649482 - Flags: review?(jgriffin) → review+
So there are two deps left that aren't in the in-tree virtualenv, autolog and mozregression.

* autolog is used to post test results to, well, Autolog.
* mozregression is used to install Firefox from downloaded packages.

Neither of these are needed in the 'make tps' scenario in which TPS would be running from the in-tree virtualenv.

The post-test processing that sends emails and posts results to autolog could all be moved to coversheet; I think this could be done by having TPS write all the results to a file (in JSON, probably) and then have coversheet parse this and handle the emailing/posting.

For mozregression, it would be nice to retain the ability in the core TPS package to work with an arbitrary Firefox archive.  I think we can replace the use of mozregression with mozinstall (which is part of mozbase and is already in the tree).

After these things are done, we won't have any deps which aren't in m-c!
Depends on: 796998
I have removed autolog from tps. I've also added the handling of the tps_result.json file to coversheet (https://github.com/jonallengriffin/coversheet). I will be sending you a pull-request for the coversheet changes.
Attachment #676399 - Flags: review?(jgriffin)
Looks good!  We can also remove the 'mozautoeslib' dep from setup.py.

I've already merged the coversheet changes.  I'm waiting to deploy them on the TPS server until it gets done with a big batch of changes it's testing.  Once it's idle, I'll deploy the coversheet changes, and then land this.  (If I landed this first, it would break TPS until I could deploy the coversheet changes.)
I just deployed the coversheet changes to the server.
Attachment #676399 - Flags: review?(jgriffin) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e43a2b8ee840
Assignee: nobody → samdgarrett
Target Milestone: --- → mozilla19
https://hg.mozilla.org/mozilla-central/rev/e43a2b8ee840
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.