Last Comment Bug 771608 - Time tag causes crash with text based profile
: Time tag causes crash with text based profile
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla16
Assigned To: Benoit Girard (:BenWa)
:
Mentors:
: 772223 (view as bug list)
Depends on:
Blocks: 769989
  Show dependency treegraph
 
Reported: 2012-07-06 12:02 PDT by Benoit Girard (:BenWa)
Modified: 2012-07-10 13:20 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (989 bytes, patch)
2012-07-06 12:02 PDT, Benoit Girard (:BenWa)
ehsan: review+
Details | Diff | Review

Description Benoit Girard (:BenWa) 2012-07-06 12:02:10 PDT
Created attachment 639753 [details] [diff] [review]
patch
Comment 1 Vladimir Vukicevic [:vlad] [:vladv] 2012-07-06 12:44:21 PDT
Comment on attachment 639753 [details] [diff] [review]
patch

One thought -- to prevent this from happening in the future, it might be better to explicitly list out all the tags here (can be done in a switch statement, since they're all characters), and have an assertion failure in the default case.  Though I think you want to get rid of the text based profiles entirely, so maybe not a big deal.
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-06 13:24:53 PDT
Comment on attachment 639753 [details] [diff] [review]
patch

Review of attachment 639753 [details] [diff] [review]:
-----------------------------------------------------------------

What Vlad said, but that can happen in a followup.
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-06 13:40:50 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/680840cf39b3
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-07-07 12:02:06 PDT
https://hg.mozilla.org/mozilla-central/rev/680840cf39b3
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-07-10 13:20:07 PDT
*** Bug 772223 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.