Last Comment Bug 771621 - Check sameDocument on location change
: Check sameDocument on location change
Status: RESOLVED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 16
Assigned To: Brian Nicholson (:bnicholson)
:
Mentors:
Depends on:
Blocks: 753102
  Show dependency treegraph
 
Reported: 2012-07-06 12:37 PDT by Brian Nicholson (:bnicholson)
Modified: 2012-07-09 21:53 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (1.05 KB, patch)
2012-07-06 12:37 PDT, Brian Nicholson (:bnicholson)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Brian Nicholson (:bnicholson) 2012-07-06 12:37:50 PDT
Created attachment 639760 [details] [diff] [review]
patch

We used to return early if sameDocument was true, but it looks like we lost this in bug 753102.
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-06 12:46:01 PDT
Comment on attachment 639760 [details] [diff] [review]
patch

Looks like this was removed because we moved setTitle(...) runnable:
http://hg.mozilla.org/mozilla-central/rev/9af545c94146#l6.262

To here:
http://hg.mozilla.org/mozilla-central/rev/9af545c94146#l3.70

Note the "//if (sameDocument)"

Yes, we need to keep this check in handleLocationChange. Can you nuke the "//if (sameDocument)" comment too?
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2012-07-06 12:46:17 PDT
We need to uplift this too
Comment 3 Brian Nicholson (:bnicholson) 2012-07-06 22:50:49 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/480c74c5e36d
Comment 4 Brian Nicholson (:bnicholson) 2012-07-06 22:52:42 PDT
Comment on attachment 639760 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 753102
User impact if declined: unexpected behavior when opening anchor from page (e.g., favicon disappears)
Testing completed (on m-c, etc.): just landed on inbound
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-07-07 11:59:50 PDT
https://hg.mozilla.org/mozilla-central/rev/480c74c5e36d
Comment 6 Brian Nicholson (:bnicholson) 2012-07-09 21:53:48 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/189d7177a904

Note You need to log in before you can comment on or make changes to this bug.