Last Comment Bug 771727 - d-pad gets stuck in tabs panel after it goes away
: d-pad gets stuck in tabs panel after it goes away
Status: RESOLVED FIXED
: access
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: Firefox 16
Assigned To: Eitan Isaacson [:eeejay]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-06 17:51 PDT by Eitan Isaacson [:eeejay]
Modified: 2012-07-13 10:38 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Truely hide tabs panel so the directional controller does not stay in it. (1.94 KB, patch)
2012-07-06 17:52 PDT, Eitan Isaacson [:eeejay]
sriram.mozilla: review+
Details | Diff | Splinter Review
Block focus in tabs panel when it is hidden. (1.99 KB, patch)
2012-07-11 16:06 PDT, Eitan Isaacson [:eeejay]
sriram.mozilla: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Eitan Isaacson [:eeejay] 2012-07-06 17:51:43 PDT
This is probably because it is never explicitly hidden.
Comment 1 Eitan Isaacson [:eeejay] 2012-07-06 17:52:14 PDT
Created attachment 639869 [details] [diff] [review]
Truely hide tabs panel so the directional controller does not stay in it.
Comment 2 Sriram Ramasubramanian [:sriram] 2012-07-10 11:20:11 PDT
Comment on attachment 639869 [details] [diff] [review]
Truely hide tabs panel so the directional controller does not stay in it.

Review of attachment 639869 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine. I'm not sure if show/hide of tabs-ui can race with animation.
If so, we might need to look into other ways/places to do this change.
Comment 3 Eitan Isaacson [:eeejay] 2012-07-11 16:06:47 PDT
Created attachment 641244 [details] [diff] [review]
Block focus in tabs panel when it is hidden.

Here, this just toggles focus settings.
Comment 4 Sriram Ramasubramanian [:sriram] 2012-07-11 16:08:03 PDT
Comment on attachment 641244 [details] [diff] [review]
Block focus in tabs panel when it is hidden.

Review of attachment 641244 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Comment 5 Eitan Isaacson [:eeejay] 2012-07-11 16:12:26 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/61d879a04b01
Comment 6 Ed Morley [:emorley] 2012-07-12 09:36:59 PDT
https://hg.mozilla.org/mozilla-central/rev/61d879a04b01
Comment 7 Marco Zehe (:MarcoZ) on PTO until August 15 2012-07-13 01:00:49 PDT
Comment on attachment 641244 [details] [diff] [review]
Block focus in tabs panel when it is hidden.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): unknown
User impact if declined: If the tabs panel goes away, accessibility is not notified correctly, so users think they're still in the tab panel even though they are not. Keyboard behavior is inconsistent and may produce unpredictable results.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): None known.
String or UUID changes made by this patch: None.
Comment 8 Marco Zehe (:MarcoZ) on PTO until August 15 2012-07-13 01:01:52 PDT
Testing completed (on m-c, etc.): Yes, verified in a local build.
Comment 9 Alex Keybl [:akeybl] 2012-07-13 10:04:15 PDT
Comment on attachment 641244 [details] [diff] [review]
Block focus in tabs panel when it is hidden.

[Triage Comment]
Approved for FF15 given that the a11y reward outweighs the near-zero risk.
Comment 10 Marco Zehe (:MarcoZ) on PTO until August 15 2012-07-13 10:38:45 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/7e10f72cdfa9

Note You need to log in before you can comment on or make changes to this bug.