Last Comment Bug 771795 - Stop over-invalidating SVG
: Stop over-invalidating SVG
Status: RESOLVED FIXED
: perf
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 08:26 PDT by Jonathan Watt [:jwatt]
Modified: 2012-07-08 10:50 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (12.37 KB, patch)
2012-07-07 08:27 PDT, Jonathan Watt [:jwatt]
cam: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-07-07 08:26:59 PDT
We are currently massively over invalidating, and no longer need to any more.
Comment 1 Jonathan Watt [:jwatt] 2012-07-07 08:27:55 PDT
Created attachment 639960 [details] [diff] [review]
patch
Comment 2 Jet Villegas (:jet) 2012-07-07 10:10:14 PDT
Seems a good time to address this comment:
// XXXSDL Let FinishAndStoreOverflow do this.

...or remove it entirely if no longer applicable.
Comment 3 Jonathan Watt [:jwatt] 2012-07-07 10:34:18 PDT
(In reply to Jet Villegas (:jet) from comment #2)
> Seems a good time to address this comment:
> // XXXSDL Let FinishAndStoreOverflow do this.

It's not clear right now how that code should look after Matt's DLBI work, so for now I'd just like to leave it as it is. Besides that, the rapid release process rules demand that I'm able to disable or back out my work if it turns out something bad requires it on branches, so I'd rather leave the "easy disable" route intact.
Comment 4 Cameron McCormack (:heycam) 2012-07-07 23:16:59 PDT
Comment on attachment 639960 [details] [diff] [review]
patch

(Stealing with permission.)
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-07-08 10:50:55 PDT
https://hg.mozilla.org/mozilla-central/rev/fa1bf35aae2e

Note You need to log in before you can comment on or make changes to this bug.